summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2020-05-30 12:40:37 +0200
committerNicolas Iooss2020-05-30 12:40:37 +0200
commited68aee36ed174020c599bdfe0893dc627ca6697 (patch)
tree1d28e1552dc9164ade3e66fe09e13a82b7ca480f
parent3be07aafea85fe7fe7d7bff95f38977375fefc3d (diff)
downloadaur-ed68aee36ed174020c599bdfe0893dc627ca6697.tar.gz
sudo-selinux 1.9.0-1 update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
-rw-r--r--sudo_logsrvd.service13
3 files changed, 35 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 798b55f199b5..d93994a00bff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sudo-selinux
pkgdesc = Give certain users the ability to run some commands as root - SELinux support
- pkgver = 1.8.31.p1
+ pkgver = 1.9.0
pkgrel = 1
url = https://www.sudo.ws/sudo/
install = sudo.install
@@ -12,18 +12,22 @@ pkgbase = sudo-selinux
depends = pam-selinux
depends = libldap
depends = libselinux
- provides = sudo=1.8.31.p1-1
- provides = selinux-sudo=1.8.31.p1-1
+ provides = sudo=1.9.0-1
+ provides = selinux-sudo=1.9.0-1
conflicts = sudo
conflicts = selinux-sudo
- backup = etc/sudoers
backup = etc/pam.d/sudo
- source = https://www.sudo.ws/sudo/dist/sudo-1.8.31p1.tar.gz
- source = https://www.sudo.ws/sudo/dist/sudo-1.8.31p1.tar.gz.sig
+ backup = etc/sudo.conf
+ backup = etc/sudo_logsrvd.conf
+ backup = etc/sudoers
+ source = https://www.sudo.ws/sudo/dist/sudo-1.9.0.tar.gz
+ source = https://www.sudo.ws/sudo/dist/sudo-1.9.0.tar.gz.sig
+ source = sudo_logsrvd.service
source = sudo.pam
validpgpkeys = 59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB
- sha256sums = c73cfdfbc1c5cc259fcc3a355e1bacfed99c5580daeadec9704a24cd5e6d15d8
+ sha256sums = ab231439c5dfdf4ecbef74f10d5f7e9686c2255c2f3887085b5c5e13281bf95c
sha256sums = SKIP
+ sha256sums = 8b91733b73171827c360a3e01f4692772b78e62ceca0cf0fd4b770aba35081a1
sha256sums = d1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2
pkgname = sudo-selinux
diff --git a/PKGBUILD b/PKGBUILD
index d8f86400c8e1..a3dbb6404c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=sudo-selinux
-_sudover=1.8.31p1
+_sudover=1.9.0
pkgver=${_sudover/p/.p}
pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root - SELinux support"
@@ -21,12 +21,17 @@ depends=('glibc' 'libgcrypt' 'pam-selinux' 'libldap' 'libselinux')
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
-backup=('etc/sudoers' 'etc/pam.d/sudo')
+backup=('etc/pam.d/sudo'
+ 'etc/sudo.conf'
+ 'etc/sudo_logsrvd.conf'
+ 'etc/sudoers')
install=${pkgname/-selinux}.install
source=(https://www.sudo.ws/sudo/dist/${pkgname/-selinux}-$_sudover.tar.gz{,.sig}
+ sudo_logsrvd.service
sudo.pam)
-sha256sums=('c73cfdfbc1c5cc259fcc3a355e1bacfed99c5580daeadec9704a24cd5e6d15d8'
+sha256sums=('ab231439c5dfdf4ecbef74f10d5f7e9686c2255c2f3887085b5c5e13281bf95c'
'SKIP'
+ '8b91733b73171827c360a3e01f4692772b78e62ceca0cf0fd4b770aba35081a1'
'd1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2')
validpgpkeys=('59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB')
@@ -66,6 +71,9 @@ package() {
cd "$srcdir/${pkgname/-selinux}-$_sudover"
make DESTDIR="$pkgdir" install
+ # sudo_logsrvd service file (taken from sudo-logsrvd-1.9.0-1.el8.x86_64.rpm)
+ install -Dm644 -t "$pkgdir/usr/lib/systemd/system" ../sudo_logsrvd.service
+
# Remove sudoers.dist; not needed since pacman manages updates to sudoers
rm "$pkgdir/etc/sudoers.dist"
diff --git a/sudo_logsrvd.service b/sudo_logsrvd.service
new file mode 100644
index 000000000000..a62fef1c137a
--- /dev/null
+++ b/sudo_logsrvd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Sudo central log server
+Documentation=man:sudo_logsrvd(8) man:sudo_logsrvd.conf(5)
+Documentation=https://www.sudo.ws/man.html
+After=syslog.target network.target auditd.service
+
+[Service]
+ExecStart=/usr/bin/sudo_logsrvd -n
+KillMode=process
+Type=exec
+
+[Install]
+WantedBy=multi-user.target