summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryadieet2016-11-19 03:09:34 +0700
committeryadieet2016-11-19 03:09:34 +0700
commit56367dea45afec340235b03603ed5c88ea6e24b9 (patch)
tree454e612975eb29ce5748d8e4aa464e24f64bbe52
downloadaur-56367dea45afec340235b03603ed5c88ea6e24b9.tar.gz
1.0-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e40db58f165c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sudx
+ pkgdesc = Run `su --login <user>` shell via dbus-run-session, useful for running GUI/X applications as another user.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/yadieet/sudx
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = systemd
+ makedepends = python
+ depends = dbus
+ depends = util-linux
+ options = strip
+ source = https://www.kernel.org/pub/linux/utils/util-linux/v2.28/util-linux-2.28.2.tar.xz
+ source = https://www.kernel.org/pub/linux/utils/util-linux/v2.28/util-linux-2.28.2.tar.sign
+ source = https://raw.githubusercontent.com/yadieet/sudx/09e6ddb38465be53a1a1e276585cf53eb0b73114/sudx.patch
+ md5sums = 46a232a37bce45371a86d19300edc47a
+ md5sums = SKIP
+ md5sums = e13b6cd9cd32d4d31becf7b27f4e2f08
+
+pkgname = sudx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73154c71d528
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: yadieet <yadieet@gmail.com>
+
+pkgname=sudx
+pkgver=1.0
+pkgrel=1
+pkgdesc="Run \`su --login <user>\` shell via dbus-run-session, useful for running GUI/X applications as another user."
+url="https://github.com/yadieet/sudx"
+arch=('i686' 'x86_64')
+depends=('dbus' 'util-linux')
+makedepends=('systemd' 'python')
+license=('GPL2')
+options=('strip')
+ulmajver=2.28
+ulminver=2
+source=("https://www.kernel.org/pub/linux/utils/util-linux/v$ulmajver/util-linux-$ulmajver.$ulminver.tar."{xz,sign}
+ "https://raw.githubusercontent.com/yadieet/sudx/09e6ddb38465be53a1a1e276585cf53eb0b73114/sudx.patch")
+md5sums=('46a232a37bce45371a86d19300edc47a'
+ 'SKIP'
+ 'e13b6cd9cd32d4d31becf7b27f4e2f08')
+
+prepare() {
+ cd "util-linux-$ulmajver.$ulminver"
+ patch -p1 -i ../sudx.patch
+}
+
+build() {
+ cd "util-linux-$ulmajver.$ulminver"
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --bindir=/usr/bin \
+ --localstatedir=/run \
+ --enable-fs-paths-extra=/usr/bin \
+ --enable-raw \
+ --enable-vipw \
+ --enable-newgrp \
+ --enable-chfn-chsh \
+ --enable-write \
+ --enable-mesg \
+ --enable-libmount-force-mountinfo \
+ --with-python=3
+ make su
+}
+
+package() {
+ cd "util-linux-$ulmajver.$ulminver"
+ install -D -m4755 su ${pkgdir}/usr/bin/sudx
+}
+