summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSrevin Saju2020-03-12 21:14:57 +0300
committerSrevin Saju2020-03-12 21:14:57 +0300
commitff4552afcbe19c07751083006002ff7136fe9d14 (patch)
tree97edf65334591c00dfb268f8634f1b47999fc492
downloadaur-ff4552afcbe19c07751083006002ff7136fe9d14.tar.gz
INIT
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d5e6873c0b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sugar-artwork-git
+ pkgdesc = Sugar icons and themes
+ pkgver = 0.116.g
+ pkgrel = 5
+ url = https://sugarlabs.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = gtk2
+ makedepends = gtk3
+ makedepends = icon-naming-utils
+ makedepends = python
+ makedepends = xorg-xcursorgen
+ optdepends = gtk2: GTK+ 2 theme
+ optdepends = gtk3: GTK+ 3 theme
+ source = git+https://github.com/sugarlabs/sugar-artwork.git
+ sha256sums = SKIP
+
+pkgname = sugar-artwork-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ee887c8efae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Srevin Saju <srevin03@gmail.com>
+
+pkgname=sugar-artwork-git
+pkgver=0.116.g
+pkgrel=5
+pkgdesc="Sugar icons and themes"
+arch=('x86_64')
+url="https://sugarlabs.org/"
+license=('LGPL')
+makedepends=('gtk2' 'gtk3' 'icon-naming-utils' 'python' 'xorg-xcursorgen')
+optdepends=('gtk2: GTK+ 2 theme'
+ 'gtk3: GTK+ 3 theme')
+source=("git+https://github.com/sugarlabs/sugar-artwork.git")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+ chmod +x ./autogen.sh
+ ./autogen.sh --prefix=/usr --with-python3
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}