summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhbhkx2020-02-01 15:47:12 +0800
committerhbhkx2020-02-01 15:47:12 +0800
commit9d22616e84c4e7abb437bcb1b711f04399a7e23f (patch)
tree600fa0c7bab526a4ed3a14e3dddd98f6bcdbe692
parentffd642fddc5358ea90f723c0863dc1c1fcd2e54e (diff)
downloadaur-suitesparse-mkl.tar.gz
install only calculation parts
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
-rw-r--r--suitesparse-mkl_tbb.patch74
3 files changed, 86 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 622234be3c2f..fc1e9beaf96c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,25 @@
pkgbase = suitesparse-mkl
- pkgdesc = A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB)
+ pkgdesc = A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB) used in julia
pkgver = 5.6.0
- pkgrel = 3
+ pkgrel = 4
url = http://faculty.cse.tamu.edu/davis/suitesparse.html
arch = i686
arch = x86_64
license = GPL
makedepends = intel-compiler-base
makedepends = intel-fortran-compiler
- makedepends = cmake
- depends = metis
depends = intel-mkl
depends = intel-tbb_psxe
provides = umfpack
- provides = graphblas=3.1.1
provides = suitesparse=5.6.0
conflicts = umfpack
- conflicts = graphblas
conflicts = suitesparse
replaces = umfpack
- replaces = graphblas
replaces = suitesparse
source = https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v5.6.0.tar.gz
source = suitesparse-mkl_tbb.patch
sha1sums = 3de08b5ab02610ed0446225aad2445696616fae5
- sha1sums = 82a0f7a84af1ee1df52416cd436d9a5e915b1e67
+ sha1sums = 06e012e3042660f9eb00a3d4acfe52b19e26a24b
pkgname = suitesparse-mkl
diff --git a/PKGBUILD b/PKGBUILD
index 0f4b74e66786..0d81acf4b638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,20 @@
pkgname=suitesparse-mkl
pkgver=5.6.0
-pkgrel=3
-pkgdesc="A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB)"
+pkgrel=4
+pkgdesc="A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB) used in julia"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('i686' 'x86_64')
-gblasver=3.1.1
-conflicts=('umfpack' 'graphblas' 'suitesparse')
-provides=('umfpack' "graphblas=${gblasver}" "suitesparse=${pkgver}")
-replaces=('umfpack' 'graphblas' 'suitesparse')
-depends=('metis' 'intel-mkl' 'intel-tbb_psxe')
-makedepends=('intel-compiler-base' 'intel-fortran-compiler' 'cmake')
+conflicts=('umfpack' 'suitesparse')
+provides=('umfpack' "suitesparse=${pkgver}")
+replaces=('umfpack' 'suitesparse')
+depends=('intel-mkl' 'intel-tbb_psxe')
+makedepends=('intel-compiler-base' 'intel-fortran-compiler')
license=('GPL')
options=()
source=("https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v${pkgver}.tar.gz" suitesparse-mkl_tbb.patch)
sha1sums=('3de08b5ab02610ed0446225aad2445696616fae5'
- '82a0f7a84af1ee1df52416cd436d9a5e915b1e67')
+ '06e012e3042660f9eb00a3d4acfe52b19e26a24b')
prepare() {
# Fix linking with intel-tbb
@@ -27,7 +26,7 @@ prepare() {
build() {
cd ${srcdir}/SuiteSparse-${pkgver}
- JOBS=8 make
+ JOBS=8 make library
}
diff --git a/suitesparse-mkl_tbb.patch b/suitesparse-mkl_tbb.patch
index f86ab5db22be..3772c3f4eda9 100644
--- a/suitesparse-mkl_tbb.patch
+++ b/suitesparse-mkl_tbb.patch
@@ -20,6 +20,15 @@
ifneq ($(AUTOCC),no)
ifneq ($(shell which icc 2>/dev/null),)
+@@ -309,7 +309,7 @@
+ # Performance Library
+ # -DGPU_BLAS enable the use of the CUDA BLAS
+
+- CHOLMOD_CONFIG ?= $(GPU_CONFIG)
++ CHOLMOD_CONFIG ?= -DNPARTITION $(GPU_CONFIG)
+
+ #---------------------------------------------------------------------------
+ # SuiteSparseQR configuration:
@@ -325,8 +325,8 @@
SPQR_CONFIG ?= $(GPU_CONFIG)
@@ -39,3 +48,68 @@
I_WITH_PARTITION =
LIB_WITH_PARTITION =
CONFIG_PARTITION = -DNPARTITION -DNCAMD
+--- SuiteSparse-5.6.0/Makefile.orig 2020-01-15 17:30:11.180000000 +0800
++++ SuiteSparse-5.6.0/Makefile 2020-01-15 17:34:31.390000000 +0800
+@@ -12,7 +12,7 @@
+ # Compile the default rules for each package
+ go: metis
+ ( cd SuiteSparse_config && $(MAKE) )
+- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
++# ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+ ( cd AMD && $(MAKE) )
+ ( cd BTF && $(MAKE) )
+ ( cd CAMD && $(MAKE) )
+@@ -30,7 +30,7 @@
+ ( cd GPUQREngine && $(MAKE) )
+ endif
+ ( cd SPQR && $(MAKE) )
+- ( cd GraphBLAS && $(MAKE) JOBS=$(JOBS) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
++# ( cd GraphBLAS && $(MAKE) JOBS=$(JOBS) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+ # ( cd PIRO_BAND && $(MAKE) )
+ # ( cd SKYLINE_SVD && $(MAKE) )
+
+@@ -38,7 +38,7 @@
+ # (note that CSparse is not installed; CXSparse is installed instead)
+ install: metisinstall
+ ( cd SuiteSparse_config && $(MAKE) install )
+- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' install )
++# ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' install )
+ ( cd AMD && $(MAKE) install )
+ ( cd BTF && $(MAKE) install )
+ ( cd CAMD && $(MAKE) install )
+@@ -55,7 +55,7 @@
+ ( cd GPUQREngine && $(MAKE) install )
+ endif
+ ( cd SPQR && $(MAKE) install )
+- ( cd GraphBLAS && $(MAKE) JOBS=$(JOBS) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' install )
++# ( cd GraphBLAS && $(MAKE) JOBS=$(JOBS) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' install )
+ # ( cd PIRO_BAND && $(MAKE) install )
+ # ( cd SKYLINE_SVD && $(MAKE) install )
+ $(CP) README.txt $(INSTALL_DOC)/SuiteSparse_README.txt
+@@ -116,7 +116,7 @@
+ # the static library
+ library: metis
+ ( cd SuiteSparse_config && $(MAKE) )
+- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' library )
++# ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' library )
+ ( cd AMD && $(MAKE) library )
+ ( cd BTF && $(MAKE) library )
+ ( cd CAMD && $(MAKE) library )
+@@ -134,7 +134,7 @@
+ ( cd GPUQREngine && $(MAKE) library )
+ endif
+ ( cd SPQR && $(MAKE) library )
+- ( cd GraphBLAS && $(MAKE) JOBS=$(JOBS) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' library )
++# ( cd GraphBLAS && $(MAKE) JOBS=$(JOBS) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' library )
+ # ( cd PIRO_BAND && $(MAKE) library )
+ # ( cd SKYLINE_SVD && $(MAKE) library )
+
+@@ -220,7 +220,7 @@
+ # Create the PDF documentation
+ docs:
+ ( cd GraphBLAS && $(MAKE) docs )
+- ( cd Mongoose && $(MAKE) docs )
++# ( cd Mongoose && $(MAKE) docs )
+ ( cd AMD && $(MAKE) docs )
+ ( cd CAMD && $(MAKE) docs )
+ ( cd KLU && $(MAKE) docs )