summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhbhkx2020-01-15 17:13:26 +0800
committerhbhkx2020-01-15 17:13:26 +0800
commit3f07f610cf2d13f4acfdf282d58f8eee348b2d7e (patch)
treec4d5ab619bce7c6111bd4063a15df215dfcec6c5
parent33a0d46d2792090632411688b4b1cd7dc14f574a (diff)
downloadaur-3f07f610cf2d13f4acfdf282d58f8eee348b2d7e.tar.gz
fix PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD29
2 files changed, 8 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d2250714f15..ed0adc79daa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = suitesparse-mkl
pkgdesc = A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB)
pkgver = 5.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://faculty.cse.tamu.edu/davis/suitesparse.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 86feeb6ef4b9..9c196e7eb909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=suitesparse-mkl
pkgver=5.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of sparse matrix libraries (compiled with the Intel MKL and Intel TBB)"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('i686' 'x86_64')
@@ -21,32 +21,17 @@ sha1sums=('3de08b5ab02610ed0446225aad2445696616fae5'
prepare() {
# Fix linking with intel-tbb
- cd SuiteSparse
- patch -p1 -i ../suitesparse-link-tbb.patch
+ cd ${srcdir}
+ patch -p0 suitesparse-mkl_tbb.patch
}
build() {
- cd "$srcdir"/SuiteSparse
-
- source /opt/intel/mkl/bin/mklvars.sh intel64
- source /opt/intel/composerxe/linux/bin/compilervars.sh intel64
- export BLAS="-L/opt/intel/mkl/lib/intel64 -lmkl_rt"
- TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib/libmetis.so make
+ cd ${srcdir}/SuiteSparse
+ JOBS=8 make
}
package() {
- cd "${srcdir}"/SuiteSparse
- install -dm755 "${pkgdir}"/usr/{include,lib}
-
- source /opt/intel/mkl/bin/mklvars.sh intel64
- source /opt/intel/composerxe/linux/bin/compilervars.sh intel64
- export BLAS="-L/opt/intel/mkl/lib/intel64 -lmkl_rt"
- export LAPACK="-L/opt/intel/mkl/lib/intel64 -lmkl_rt"
-
- TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib/libmetis.so \
- make INSTALL_LIB="${pkgdir}"/usr/lib INSTALL_INCLUDE="${pkgdir}"/usr/include install
-
- # fix RPATH
- chrpath -d "$pkgdir"/usr/lib/*
+ cd ${srcdir}/SuiteSparse
+ make install
}