summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2016-03-30 23:13:46 -0700
committerAntony Lee2016-03-30 23:18:37 -0700
commitadf33ebca07f50031b445d6826b97cb08128310b (patch)
treeffb0906571c5d67786fd70f60712d43ab8f32b36
downloadaur-adf33ebca07f50031b445d6826b97cb08128310b.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
-rw-r--r--SuitPlayEULA.txt20
-rw-r--r--suitplay.install10
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02c918949a7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Mar 31 06:18:31 UTC 2016
+pkgbase = suitplay
+ pkgdesc = A program that determines optimal play of suit combinations in bridge.
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = http://home.planet.nl/~narcis45/suitplay/
+ install = suitplay.install
+ arch = any
+ license = custom
+ depends = wine
+ source = file://suitplay.zip
+ source = file://SuitPlayEULA.txt
+ md5sums = 1d42a581b1647f150921fd650dfc4ee6
+ md5sums = 3ec142762e4aa49073d571b5529774c5
+
+pkgname = suitplay
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fe61ef95b50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+# Please follow the instructions at http://home.planet.nl/~narcis45/suitplay/
+# to obtain suitplay.zip.
+
+pkgname=suitplay
+pkgver=2.1.2
+pkgrel=1
+pkgdesc='A program that determines optimal play of suit combinations in bridge.'
+arch=('any')
+url='http://home.planet.nl/~narcis45/suitplay/'
+license=('custom')
+depends=('wine')
+install="$pkgname.install"
+source=('file://suitplay.zip'
+ 'file://SuitPlayEULA.txt')
+md5sums=('1d42a581b1647f150921fd650dfc4ee6'
+ '3ec142762e4aa49073d571b5529774c5')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ cp "$srcdir/SuitPlay.exe" "$pkgdir/usr/share/$pkgname"
+
+ mkdir "$pkgdir/usr/bin"
+ cat <<EOF >"$pkgdir/usr/bin/suitplay"
+#!/bin/sh
+cd /usr/share/$pkgname
+wine SuitPlay.exe
+EOF
+ chmod a+x "$pkgdir/usr/bin/suitplay"
+
+ install -D -m644 SuitPlayEULA.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ln -s "/usr/share/licenses/$pkgname/LICENSE" "$pkgdir/usr/share/$pkgname/SuitPlayEULA.txt"
+}
diff --git a/SuitPlayEULA.txt b/SuitPlayEULA.txt
new file mode 100644
index 000000000000..7a42d418ceb6
--- /dev/null
+++ b/SuitPlayEULA.txt
@@ -0,0 +1,20 @@
+Software Licence Agreement
+
+
+
+All rights, including but not limited to copyrights and
+intellectual property rights, in and to this software are
+owned by Warmerdam, training, software & consultancy
+(Wtcs).
+
+Wtcs grants to you a non-exclusive license to use the
+software. You may not redistribute, sell, decompile, reverse
+engineer, or disassemble the software. The software
+cannot be resold, redistributed, or offered as a service
+without explicit written permission from Wtcs.
+
+Your use of the software is entirely at your own risk.
+
+The license is free of charge. Nevertheless, I would
+appreciate any donation. See www.suitplay.com.
+
diff --git a/suitplay.install b/suitplay.install
new file mode 100644
index 000000000000..d9a833072d59
--- /dev/null
+++ b/suitplay.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "You must agree to the following End-User License agreement,"
+ echo "or uninstall suitplay."
+ echo
+ cat /usr/share/licenses/suitplay/LICENSE
+}
+
+post_upgrade() {
+ post_install
+}