summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2024-01-17 11:20:40 +0100
committerAleksandar Trifunovic2024-01-17 11:20:40 +0100
commit0bf4e230f60e54428a4516471e609e488f1e32c9 (patch)
treebfb25b24ea23b7fe21c19cdebbab58b045648eff
parenta5e47725d1b01601f0fd602904ca59f47b137a6a (diff)
downloadaur-0bf4e230f60e54428a4516471e609e488f1e32c9.tar.gz
change tarball source
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc72b477e223..6141e7f51ef3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sumo
pkgdesc = Traffic simulation modelling road vehicles, public transport and pedestrians.
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = http://sumo.dlr.de
arch = i686
arch = x86_64
@@ -24,9 +24,9 @@ pkgbase = sumo
depends = python-pyproj
depends = python-pandas
depends = python-scipy
- source = https://github.com/eclipse/sumo/archive/v1_19_0.tar.gz
+ source = https://sumo.dlr.de/releases/1.19.0/sumo-src-1.19.0.tar.gz
source = sumo.desktop
- sha256sums = 4dc56e66f994b4f1378e357e2c40df55035eac29851252da2f5399b86370f249
+ sha256sums = 7643b1f8a3d7144f181542c9c7b8c72f3e8e45ba9c627912665083db0fe106cd
sha256sums = cc0ed7ad1cce228cd8c634e031c966e1795a16623f0e139ebdcc7ecd06d0bf4d
pkgname = sumo
diff --git a/PKGBUILD b/PKGBUILD
index c89795f3a13e..1d170183eb21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,21 @@ SUMO_HOME='/usr/share/sumo'
pkgname=('sumo' 'sumo-doc')
pkgbase=sumo
pkgver=1.19.0
-_pkgver="${pkgver//./_}"
-pkgrel=1
+pkgrel=2
pkgdesc="Traffic simulation modelling road vehicles, public transport and pedestrians."
arch=('i686' 'x86_64')
url="http://sumo.dlr.de"
license=('GPL')
depends=('openscenegraph' 'python' 'proj' 'fox' 'xerces-c' 'gdal' 'gl2ps' 'python-pyproj' 'python-pandas' 'python-scipy')
makedepends=('cmake' 'help2man' 'swig' 'gtest' 'gmock' 'flake8' 'autopep8' 'python-setuptools')
-source=("https://github.com/eclipse/sumo/archive/v${_pkgver}.tar.gz"
+source=("https://sumo.dlr.de/releases/${pkgver}/sumo-src-${pkgver}.tar.gz"
"${pkgbase}.desktop")
-sha256sums=('4dc56e66f994b4f1378e357e2c40df55035eac29851252da2f5399b86370f249'
+sha256sums=('7643b1f8a3d7144f181542c9c7b8c72f3e8e45ba9c627912665083db0fe106cd'
'cc0ed7ad1cce228cd8c634e031c966e1795a16623f0e139ebdcc7ecd06d0bf4d')
prepare() {
- cd ${pkgbase}-${_pkgver}
-
- # workaround for invalid version string generated by sumo
- sed -i "42i\ return 'v1_19_00'" tools/build/version.py
+ cd ${pkgbase}-${pkgver}
cmake -H. -Bbuild \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
@@ -37,14 +33,14 @@ prepare() {
}
build() {
- cd ${pkgbase}-${_pkgver}
+ cd ${pkgbase}-${pkgver}
cmake --build build
cmake --build build -- man
}
# example tests still fails
# check() {
-# cd ${pkgbase}-${_pkgver}
+# cd ${pkgbase}-${pkgver}
# cmake --build build -- test
# }
@@ -52,7 +48,7 @@ package_sumo() {
optdepends=('java-runtime-common: for executing Jar files like TraCI4J'
"python2: for executing various python scripts in $SUMO_HOME/tools")
- cd ${pkgbase}-${_pkgver}
+ cd ${pkgbase}-${pkgver}
# Installs just the bin files
cmake --build build -- DESTDIR="${pkgdir}/" install
@@ -69,7 +65,7 @@ EOF
}
package_sumo-doc() {
- cd ${pkgbase}-${_pkgver}
+ cd ${pkgbase}-${pkgver}
install -d ${pkgdir}/usr/share/doc/${pkgbase}