summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-09-29 21:45:35 -0400
committerChris Severance2017-09-29 21:45:35 -0400
commitff38857ec1dfcdc8c936c6e561b5de919d3f1571 (patch)
treea06205d50ea6a86f9f0609139de3729c88db2c35
parent646975af5242e2acedd0f52390561a9d9a4699b6 (diff)
downloadaur-ff38857ec1dfcdc8c936c6e561b5de919d3f1571.tar.gz
Update for kernel 4.13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--sunix-patch-alt_speed-kernel-4-13.patch12
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09642346301f..e0ece6cc3d66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jul 18 20:02:54 UTC 2017
+# Sat Sep 30 01:41:13 UTC 2017
pkgbase = sunix-snx
pkgdesc = kernel module driver for Sunix SUN1889 SUN1989 SUN1999 SUN2212 SUN2410 UL7502AQ UL7512EQ UL7522EQ PCI PCIe multi I/O parallel serial RS-232 422 485 port Dell Lenovo Acer Startech
pkgver = 2.0.4_2
- pkgrel = 1
+ pkgrel = 2
url = http://www.sunix.com/
install = sunix-snx-install.sh
arch = i686
@@ -20,8 +20,10 @@ pkgbase = sunix-snx
depends = linux-headers
source = http://www.sunix.com.tw/en/download.php?pid=1479&file=driver&file_link=download/driver/2016/20160706173626_snx_V2.0.4.2.tar.gz
source = sunix-patch-signal_pending-kernel-4-11.patch
+ source = sunix-patch-alt_speed-kernel-4-13.patch
sha256sums = 56ef81518184116bd4fd158e39d0e5ceace53f26f85398371bb230d44da4ff9a
sha256sums = b589ba0e9d18638b26c8584cefaa5ed500a4984b9d03ed1d6863ba34a559742c
+ sha256sums = 7743a276081292b6b97fc6a836e1a8331eb10396619882bb611b81b971df3988
pkgname = sunix-snx
diff --git a/PKGBUILD b/PKGBUILD
index 257819715eaf..780d97b1c30c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -90,7 +90,7 @@ set -u
# http://wiki.linuxcnc.org/cgi-bin/wiki.pl?Startech
pkgname='sunix-snx'
pkgver='2.0.4_2'
-pkgrel='1'
+pkgrel='2'
pkgdesc='kernel module driver for Sunix SUN1889 SUN1989 SUN1999 SUN2212 SUN2410 UL7502AQ UL7512EQ UL7522EQ PCI PCIe multi I/O parallel serial RS-232 422 485 port Dell Lenovo Acer Startech'
arch=('i686' 'x86_64')
url='http://www.sunix.com/'
@@ -107,9 +107,11 @@ source=(
# http://rglinuxtech.com/?p=1930
# https://forum.manjaro.org/t/error-with-rtl8812au/24066
'sunix-patch-signal_pending-kernel-4-11.patch'
+ 'sunix-patch-alt_speed-kernel-4-13.patch'
)
sha256sums=('56ef81518184116bd4fd158e39d0e5ceace53f26f85398371bb230d44da4ff9a'
- 'b589ba0e9d18638b26c8584cefaa5ed500a4984b9d03ed1d6863ba34a559742c')
+ 'b589ba0e9d18638b26c8584cefaa5ed500a4984b9d03ed1d6863ba34a559742c'
+ '7743a276081292b6b97fc6a836e1a8331eb10396619882bb611b81b971df3988')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -168,6 +170,11 @@ prepare() {
# diff -pNau3 driver/snx_common.h{.orig,} > 'sunix-patch-signal_pending-kernel-4-11.patch'
patch -Nbup0 < 'sunix-patch-signal_pending-kernel-4-11.patch'
+ # diff -pNau3 driver/snx_serial.c{.orig,} > 'sunix-patch-alt_speed-kernel-4-13.patch'
+ patch -Nbup0 < 'sunix-patch-alt_speed-kernel-4-13.patch'
+
+ # Fix kernel harding error. Must do in sed in case version changes. We put in more than necessary in case the version gets shorter.
+ sed -e 's:^\(#define SNX_DRIVER_VERSION .*\)":\1\\0\\0\\0\\0\\0\\0\\0\\0":g' -i 'driver/snx_common.h'
# Forgot to clean tarball
'ma'ke -s -j1 clean
diff --git a/sunix-patch-alt_speed-kernel-4-13.patch b/sunix-patch-alt_speed-kernel-4-13.patch
new file mode 100644
index 000000000000..c2426e84c727
--- /dev/null
+++ b/sunix-patch-alt_speed-kernel-4-13.patch
@@ -0,0 +1,12 @@
+--- driver/snx_serial.c.orig 2015-07-23 03:16:58.000000000 -0400
++++ driver/snx_serial.c 2017-09-29 21:22:27.651754374 -0400
+@@ -3697,7 +3697,9 @@ static int snx_ser_open(struct tty_struc
+ tty->low_latency = (state->port->flags & SNX_UPF_LOW_LATENCY) ? 1 : 0;
+ #endif
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,13,0))
+ tty->alt_speed = 0;
++#endif
+ state->info->tty = tty;
+
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,7,0))