summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2022-01-13 13:13:21 +0800
committeryjun2022-01-13 13:13:21 +0800
commitefccbc9acf940a69361170e2347414dcb3f0a60e (patch)
tree2c73778c1261411bff771984dfc86b87e8417f16
parent4d262b3c79c875ab5681cd8192d963e8a5f2815f (diff)
downloadaur-efccbc9acf940a69361170e2347414dcb3f0a60e.tar.gz
Add aarch64 architecture support
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf0f127cd68d..64f6cdb8d0fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,15 +5,18 @@ pkgbase = sunloginclient
url = https://sunlogin.oray.com
install = sunloginclient.install
arch = x86_64
+ arch = aarch64
license = custom
depends = libappindicator-gtk3
depends = xorg-xhost
provides = sunlogin
- source = https://down.oray.com/sunlogin/linux/sunloginclient-11.0.0.36662-amd64.deb
source = runsunloginclient.service
source = LICENSE
- sha256sums = 825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0
sha256sums = 7f36a60d84741d817a0d0804bd39c8c7d7058144a6934b2abf0841446f4a56de
sha256sums = SKIP
+ source_x86_64 = https://down.oray.com/sunlogin/linux/sunloginclient-11.0.0.36662-amd64.deb
+ sha256sums_x86_64 = 825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0
+ source_aarch64 = https://down.oray.com/sunlogin/linux/sunloginclient_11.0.0.36662_arm.deb
+ sha256sums_aarch64 = 7e3d9fd33eca25e0fca07c04777d81bdc1b5832819d36b37f0773de742dcbd59
pkgname = sunloginclient
diff --git a/PKGBUILD b/PKGBUILD
index 849124f6b4fd..6c57d70df2d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,21 @@ _pkgname=sunlogin
pkgver=11.0.0.36662
pkgrel=3
pkgdesc="Proprietary software that supports remote control of mobile devices, Windows, Mac, Linux and other systems.(GUI version)"
-arch=("x86_64")
+arch=("x86_64" "aarch64")
url="https://sunlogin.oray.com"
depends=("libappindicator-gtk3"
'xorg-xhost')
license=('custom')
provides=('sunlogin')
-source=("https://down.oray.com/${_pkgname}/linux/${pkgname}-${pkgver}-amd64.deb"
- "runsunloginclient.service"
+source=("runsunloginclient.service"
'LICENSE')
+source_x86_64=("https://down.oray.com/${_pkgname}/linux/${pkgname}-${pkgver}-amd64.deb")
+source_aarch64=("https://down.oray.com/${_pkgname}/linux/${pkgname}_${pkgver}_arm.deb")
install="${pkgname}.install"
-sha256sums=('825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0'
- '7f36a60d84741d817a0d0804bd39c8c7d7058144a6934b2abf0841446f4a56de'
+sha256sums=('7f36a60d84741d817a0d0804bd39c8c7d7058144a6934b2abf0841446f4a56de'
'SKIP')
+sha256sums_x86_64=('825e05405dcdd31e87a91a0bfa961c6e954f953d6ead667715924b4703e41ef0')
+sha256sums_aarch64=('7e3d9fd33eca25e0fca07c04777d81bdc1b5832819d36b37f0773de742dcbd59')
build() {
mkdir -p build