summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelvie Wong2024-03-04 21:32:23 -0800
committerKelvie Wong2024-03-04 21:32:23 -0800
commit275eb849ba7e0c2581e4a8ff601ea4f17e9df383 (patch)
tree3e7b6826761c335d763737bc41cce509560e49bb
parentd0c7e7cc0ab9b1bc61c58ca9e108fce72a567a46 (diff)
downloadaur-275eb849ba7e0c2581e4a8ff601ea4f17e9df383.tar.gz
Fix build for latest git
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef8db558fffa..947b617ce772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sunshine-git
pkgdesc = Game Stream server for Moonlight, latest git
- pkgver = nightly.dev.r214.g032680c
+ pkgver = nightly.dev.r830.gcacadc4
pkgrel = 1
url = https://github.com/LizardByte/Sunshine
install = sunshine-git.install
@@ -25,6 +25,7 @@ pkgbase = sunshine-git
depends = libxfixes
depends = libxrandr
depends = libxtst
+ depends = miniupnpc
depends = numactl
depends = openssl
depends = opus
@@ -38,7 +39,7 @@ pkgbase = sunshine-git
source = git+https://github.com/LizardByte/Sunshine.git#branch=nightly
source = git+https://github.com/moonlight-stream/moonlight-common-c.git
source = git+https://gitlab.com/eidheim/Simple-Web-Server.git
- source = git+https://github.com/ViGEm/ViGEmClient.git
+ source = git+https://github.com/LizardByte/Virtual-Gamepad-Emulation-Client.git
source = git+https://github.com/miniupnp/miniupnp.git
source = git+https://github.com/FFmpeg/nv-codec-headers.git
source = git+https://github.com/michaeltyson/TPCircularBuffer.git
diff --git a/PKGBUILD b/PKGBUILD
index 2934b9c5c5f7..90043d1d8595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=sunshine-git
-pkgver=nightly.dev.r214.g032680c
+pkgver=nightly.dev.r830.gcacadc4
pkgrel=1
pkgdesc="Game Stream server for Moonlight, latest git"
arch=('x86_64')
@@ -23,6 +23,7 @@ libxcb
libxfixes
libxrandr
libxtst
+miniupnpc
numactl
openssl
opus
@@ -49,7 +50,7 @@ source=(
git+https://github.com/LizardByte/Sunshine.git#branch=nightly
git+https://github.com/moonlight-stream/moonlight-common-c.git
git+https://gitlab.com/eidheim/Simple-Web-Server.git
-git+https://github.com/ViGEm/ViGEmClient.git
+git+https://github.com/LizardByte/Virtual-Gamepad-Emulation-Client.git
git+https://github.com/miniupnp/miniupnp.git
git+https://github.com/FFmpeg/nv-codec-headers.git
git+https://github.com/michaeltyson/TPCircularBuffer.git
@@ -78,14 +79,14 @@ pkgver() {
prepare() {
cd Sunshine
- git rm -f third-party/ffmpeg-windows-x86_64
- git rm -f third-party/ffmpeg-macos-x86_64
- git rm -f third-party/ffmpeg-macos-aarch64
- git rm -f third-party/ffmpeg-linux-aarch64
+ rm -f third-party/ffmpeg-windows-x86_64
+ rm -f third-party/ffmpeg-macos-x86_64
+ rm -f third-party/ffmpeg-macos-aarch64
+ rm -f third-party/ffmpeg-linux-aarch64
git submodule init
git config submodule.third-party/moonlight-common-c.url "${srcdir}/moonlight-common-c"
git config submodule.third-party/Simple-Web-Server.url "${srcdir}/Simple-Web-Server"
- git config submodule.third-party/ViGEmClient.url "${srcdir}/ViGEmClient"
+ git config submodule.third-party/ViGEmClient.url "${srcdir}/Virtual-Gamepad-Emulation-Client"
git config submodule.third-party/miniupnp.url "${srcdir}/miniupnp"
git config submodule.third-party/nv-codec-headers.url "${srcdir}/nv-codec-headers"
git config submodule.third-party/TPCircularBuffer.url "${srcdir}/TPCircularBuffer"