summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorΝικόλαος Κυριάκος Φυτίλης2020-06-13 15:57:57 +0300
committerΝικόλαος Κυριάκος Φυτίλης2020-06-13 16:26:51 +0300
commitc8aacb7a63e6427c96f075240473599fe7d5dbbe (patch)
tree192ad317eaba09f90833c3a0c66d73406e42619d
downloadaur-c8aacb7a63e6427c96f075240473599fe7d5dbbe.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rwxr-xr-xsunshine9
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cae8a57abff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sunshine-git
+ pkgdesc = Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield
+ pkgver = 0.4.0.q.290415dec3..
+ pkgrel = 1
+ url = http://sunshine-stream.com
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ provides = sunshine
+ conflicts = sunshine
+ source = sunshine-git::git+https://github.com/loki-47-6F-64/sunshine
+ source = sunshine
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = sunshine-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c92ef9c0496a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*pkg*
+sunshine-git/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c1d8ae198be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+_pkgname=sunshine
+pkgname=${_pkgname}-git
+pkgver=0.4.0.q.290415dec3..
+pkgrel=1
+pkgdesc="Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield"
+url="http://sunshine-stream.com"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=()
+makedepends=('git')
+provides=('sunshine')
+conflicts=("sunshine")
+source=(${pkgname}::git+https://github.com/loki-47-6F-64/sunshine
+ sunshine)
+sha512sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2|sed 's|\-|.|g')" \
+q "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ git submodule update --recursive --init
+}
+
+build() {
+ cd ${pkgname}
+ mkdir build || rm -rf build/*
+ cd build
+# export SUNSHINE_EXECUTABLE_PATH=/usr/bin/
+ cmake ..
+ make
+ sed 's/\@SUNSHINE_EXECUTABLE_PATH\@/\/usr\/bin\/sunshine \/etc\/sunshine.conf/g' ../sunshine.service.in > sunshine.service
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/" "$pkgdir/usr/lib/systemd/user/" "$pkgdir/etc/" "$pkgdir/usr/lib/sunshine/bin/"
+ cp sunshine "$pkgdir/usr/bin/"
+
+ cd ${pkgname}
+ cp build/sunshine "$pkgdir/usr/lib/sunshine/bin/"
+ cp build/sunshine.service "$pkgdir/usr/lib/systemd/user/"
+ cp assets/sunshine.conf "$pkgdir/etc/"
+
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/sunshine b/sunshine
new file mode 100755
index 000000000000..c19a459343c1
--- /dev/null
+++ b/sunshine
@@ -0,0 +1,9 @@
+#!/usr/bin/sh
+
+set -e
+
+cd
+mkdir .config/sunshine &> /dev/null || true
+cd .config/sunshine
+
+/usr/lib/sunshine/bin/sunshine $*