summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfernalknight2015-08-19 17:58:46 +0300
committerinfernalknight2015-08-19 17:58:46 +0300
commit9299b823157622ae12e49048ec214e9e9dbc32e7 (patch)
tree92936827524b5d491eb080552319956cbd3f3dfd
downloadaur-9299b823157622ae12e49048ec214e9e9dbc32e7.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6de5945ae8d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = sunvox
+ pkgdesc = Small, fast and powerful modular synthesizer with pattern-based sequencer (tracker).
+ pkgver = 1.9b
+ pkgrel = 1
+ url = http://warmplace.ru/soft/sunvox/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ depends = libx11
+ depends = glibc
+ depends = gcc-libs
+ depends = alsa-lib
+ depends = sdl
+ depends = libxcb
+ depends = libxau
+ depends = libxdmcp
+ source = http://warmplace.ru/soft/sunvox/sunvox-1.9b.zip
+ md5sums = 9c7db5297122a031829323a5c30c373c
+
+pkgname = sunvox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78de5d905eb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Anton Yermalovich <anton dork yermalovich art gmail dork com>
+pkgname=sunvox
+pkgver=1.9b
+pkgrel=1
+pkgdesc="Small, fast and powerful modular synthesizer with pattern-based sequencer (tracker)."
+arch=('i686' 'x86_64')
+url="http://warmplace.ru/soft/sunvox/"
+license=(custom)
+groups=()
+depends=('libx11'
+ 'glibc'
+ 'gcc-libs'
+ 'alsa-lib'
+ 'sdl'
+ 'libxcb'
+ 'libxau'
+ 'libxdmcp')
+makedepends=('unzip')
+source=(http://warmplace.ru/soft/sunvox/$pkgname-$pkgver.zip)
+md5sums=('9c7db5297122a031829323a5c30c373c')
+
+package() {
+
+ install -dm755 "${pkgdir}/opt/${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ if [ "$CARCH" = "x86_64" ]; then
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox" "${pkgdir}/usr/bin/sunvox"
+ else
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox" "${pkgdir}/usr/bin/sunvox"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox_lofi" "${pkgdir}/usr/bin/sunvox_lofi"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox_no_simd" "${pkgdir}/usr/bin/sunvox_no_simd"
+ fi
+
+ cp -a "${srcdir}/sunvox/examples" "${pkgdir}/opt/${pkgname}/examples"
+ cp -a "${srcdir}/sunvox/instruments" "${pkgdir}/opt/${pkgname}/instruments"
+ install -Dm644 "${srcdir}/sunvox/docs/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}