summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Herbrich2022-05-26 13:18:02 +0200
committerDennis Herbrich2022-05-26 13:39:33 +0200
commited1db738b928970b2c5b9b27b066faca9aa0e86b (patch)
tree578089b4d188d32c732e1cda358d018ae0e9f586
parent9fea241db39144fe2517889935530311310d1e64 (diff)
downloadaur-ed1db738b928970b2c5b9b27b066faca9aa0e86b.tar.gz
fix(optdepends,package): install correct binaries
Add previously unpackaged `sunvox_opengl` binary for x86_64 with its runtime dependencies listed as optdepends, as one can use the regular `sunvox` binary without `libgl` or `libxi`. Remove `sunvox_no_simd` binary for i686, as it is no longer included in the distribution archive.
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4af13fd4620..9bf1f247f7cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,6 +20,11 @@ depends=('alsa-lib'
'sdl2')
makedepends=('unzip' 'icoutils')
optdepends=('jack: jack audio server output')
+# sunvox_opengl is only provided for x86_64 architecture, and needs individual optdeps
+if [[ "$CARCH" == "x86_64" ]]; then
+ optdepends+=('libgl: required for sunvox_opengl'
+ 'libxi: required for sunvox_opengl')
+fi
source=(http://warmplace.ru/soft/sunvox/$pkgname-$pkgver.zip sunvox.desktop sunvox.xml)
sha256sums=('bf87509d1afba6eb0e0075fccad0c284a8b16311088e0df4bce4c3eae03f4b4a'
'21680b38c66e4375f0a01e496d3167fe8695ada60204c885ff63e63022b63495'
@@ -56,10 +61,10 @@ package() {
if [ "$CARCH" = "x86_64" ]; then
install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox" "${pkgdir}/usr/bin/sunvox"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox_opengl" "${pkgdir}/usr/bin/sunvox_opengl"
else
install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox" "${pkgdir}/usr/bin/sunvox"
install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_lofi" "${pkgdir}/usr/bin/sunvox_lofi"
- install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_no_simd" "${pkgdir}/usr/bin/sunvox_no_simd"
fi
cp -a "${srcdir}"/sunvox/{examples,instruments,effects} "${pkgdir}/opt/${pkgname}/"