summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Latorre2019-01-15 20:03:09 -0500
committerDavid Latorre2019-01-15 20:03:09 -0500
commit59e6689621234d4515fc11e00b4c168a5be14e91 (patch)
tree168e2b149ca24480547a658cf6f3e04543463511
downloadaur-59e6689621234d4515fc11e00b4c168a5be14e91.tar.gz
Add 1.9.4c version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b807f44aa9a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sunvox
+ pkgdesc = Small, fast and powerful modular synthesizer with pattern-based sequencer (tracker).
+ pkgver = 1.9.4c
+ pkgrel = 1
+ url = http://warmplace.ru/soft/sunvox/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ depends = libx11
+ depends = glibc
+ depends = gcc-libs
+ depends = alsa-lib
+ depends = sdl
+ depends = libxcb
+ depends = libxau
+ depends = libxdmcp
+ source = http://warmplace.ru/soft/sunvox/sunvox-1.9.4c.zip
+ md5sums = 10bbeed0e3efe9345d17127fdf7751ef
+pkgname = sunvox \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7f034cdcd02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Submitter: Anton Yermalovich <zuzu@bk.ru>
+# Maintainer: David Latorre <david@latorredev.com>
+# Contributor: zwergnase <zwergnase@posteo.de>
+
+pkgname=sunvox
+pkgver=1.9.4c
+pkgrel=1
+pkgdesc="Small, fast and powerful modular synthesizer with pattern-based sequencer (tracker)."
+arch=('i686' 'x86_64')
+url="http://warmplace.ru/soft/sunvox/"
+license=(custom)
+groups=()
+depends=(
+ 'libx11'
+ 'glibc'
+ 'gcc-libs'
+ 'alsa-lib'
+ 'sdl'
+ 'libxcb'
+ 'libxau'
+ 'libxdmcp'
+)
+makedepends=('unzip')
+source=(http://warmplace.ru/soft/sunvox/$pkgname-$pkgver.zip)
+md5sums=('10bbeed0e3efe9345d17127fdf7751ef')
+
+package() {
+ install -dm755 "${pkgdir}/opt/${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ if [ "$CARCH" = "x86_64" ]; then
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox" "${pkgdir}/usr/bin/sunvox"
+ else
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox" "${pkgdir}/usr/bin/sunvox"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_lofi" "${pkgdir}/usr/bin/sunvox_lofi"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_no_simd" "${pkgdir}/usr/bin/sunvox_no_simd"
+ fi
+ cp -a "${srcdir}/sunvox/examples" "${pkgdir}/opt/${pkgname}/examples"
+ cp -a "${srcdir}/sunvox/instruments" "${pkgdir}/opt/${pkgname}/instruments"
+ cp -a "${srcdir}/sunvox/effects" "${pkgdir}/opt/${pkgname}/effects"
+ install -Dm644 "${srcdir}/sunvox/docs/license/SunVox.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file