summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Latorre2019-01-16 09:38:02 -0500
committerDavid Latorre2019-01-16 09:38:02 -0500
commit89139467963bbe1578700e8e4bc78850bba7c0c5 (patch)
treed7d7317aec3230df0eabc799e6fc74d11b0b590c
parent05e41116ae075a2403c9cd6034219fcbbe58bf78 (diff)
downloadaur-89139467963bbe1578700e8e4bc78850bba7c0c5.tar.gz
add new link to download, the zip file now contain an icon and desktop shortcut
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD34
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 989d257c5869..0f06ae408a4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,6 @@ pkgbase = sunvox-1.x
depends = libxcb
depends = libxau
depends = libxdmcp
- source = http://warmplace.ru/soft/sunvox/sunvox-1.x-1.9.4c.zip
- md5sums = 10bbeed0e3efe9345d17127fdf7751ef
+ source = https://github.com/LatorreDev/sunvox_mirror/releases/download/1.9.4c/sunvox-1-9.4c.zip
+ sha256sums = f1bf4aedd6eaf5d626d2c66daff0e88535425beb80f56a9a8cb12cdf89057777
pkgname = sunvox-1.x \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 7b83d941d34c..fbcdcab3147f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,20 +21,22 @@ depends=(
'libxdmcp'
)
makedepends=('unzip')
-source=(./sunvox-1-9.4c.tar.gz)
-sha256sums=('4fbf1351c358cf292a0fa2cb7a6152f1b3dd46b9acf1e9aa2f0b5096b6e52e84')
+source=('https://github.com/LatorreDev/sunvox_mirror/releases/download/1.9.4c/sunvox-1-9.4c.zip')
+sha256sums=('f1bf4aedd6eaf5d626d2c66daff0e88535425beb80f56a9a8cb12cdf89057777')
package() {
- install -dm755 "${pkgdir}/opt/sunvox"
- install -dm755 "${pkgdir}/usr/share/licenses/sunvox"
- if [ "$CARCH" = "x86_64" ]; then
- install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox" "${pkgdir}/usr/bin/sunvox"
- else
- install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox" "${pkgdir}/usr/bin/sunvox"
- install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_lofi" "${pkgdir}/usr/bin/sunvox_lofi"
- install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_no_simd" "${pkgdir}/usr/bin/sunvox_no_simd"
- fi
- cp -a "${srcdir}/sunvox/examples" "${pkgdir}/opt/sunvox/examples"
- cp -a "${srcdir}/sunvox/instruments" "${pkgdir}/opt/sunvox/instruments"
- cp -a "${srcdir}/sunvox/effects" "${pkgdir}/opt/sunvox/effects"
- install -Dm644 "${srcdir}/sunvox/docs/license/SunVox.txt" "${pkgdir}/usr/share/licenses/sunvox/LICENSE"
-}
+ install -dm755 "${pkgdir}/opt/sunvox"
+ install -dm755 "${pkgdir}/usr/share/licenses/sunvox"
+ if [ "$CARCH" = "x86_64" ]; then
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86_64/sunvox" "${pkgdir}/usr/bin/sunvox"
+ install -Dm755 "${srcdir}/sunvox/assets/sunvox.desktop" "${pkgdir}/usr/share/applications/sunvox.desktop"
+ install -Dm755 "${srcdir}/sunvox/assets/sunvox.svg" "${pkgdir}/usr/share/pixmaps/sunvox.svg"
+ else
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox" "${pkgdir}/usr/bin/sunvox"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_lofi" "${pkgdir}/usr/bin/sunvox_lofi"
+ install -Dm755 "${srcdir}/sunvox/sunvox/linux_x86/sunvox_no_simd" "${pkgdir}/usr/bin/sunvox_no_simd"
+ fi
+ cp -a "${srcdir}/sunvox/examples" "${pkgdir}/opt/sunvox/examples"
+ cp -a "${srcdir}/sunvox/instruments" "${pkgdir}/opt/sunvox/instruments"
+ cp -a "${srcdir}/sunvox/effects" "${pkgdir}/opt/sunvox/effects"
+ install -Dm644 "${srcdir}/sunvox/docs/license/SunVox.txt" "${pkgdir}/usr/share/licenses/sunvox/LICENSE"
+} \ No newline at end of file