summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-01 23:50:37 -0400
committeréclairevoyant2023-05-01 23:50:37 -0400
commitc5407ffd0727dd32ebc9fdcc8885f4dc1bc28eb1 (patch)
tree9067ba4bd1647c68ef1307889ed53b9d962bbcc7
parentca1148fb03ae174462fb5d531708298acf24583f (diff)
downloadaur-c5407ffd0727dd32ebc9fdcc8885f4dc1bc28eb1.tar.gz
sunwait: update deps, source, license, url; respect compilation flags; install docs
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 24 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f4b346a291f..75a89d835c5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = sunwait
pkgdesc = A small C program for calculating sunrise and sunset times
- pkgver = 0.8
+ pkgver = 0.9.1
pkgrel = 1
- url = http://www.risacher.org/sunwait/
+ url = https://www.risacher.org/sunwait/
arch = i686
arch = x86_64
- license = GPL
- depends = gcc-libs
- source = http://downloads.sourceforge.net/project/sunwait4windows/sunwait0-8.tar
- md5sums = 97b062fb4adce37d4af59f5b42675fce
+ license = GPL3
+ depends = glibc
+ source = sunwait-0.9.1.tar.gz::https://github.com/risacher/sunwait/archive/refs/tags/0.9.1.tar.gz
+ b2sums = e623a4d0d05f09ae52671679d84ea6700f667f7629d80873930a36596dd19a9215e4fa62f107172d9e70614077059be6d864d01476651f6c18afa172f64f767d
pkgname = sunwait
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 51d5b7035bee..50079c510938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,25 @@
-# Maintainer: Kyle Keen <keenerd@gmail.com>
-# Contributor: Tom Vincent Tom Vincent <http://tlvince.com/contact>
+# Maintainer: éclairevoyant
pkgname=sunwait
-pkgver=0.8
-_pkgver=0-8
+pkgver=0.9.1
pkgrel=1
-url="http://www.risacher.org/sunwait/"
+url="https://www.risacher.org/sunwait/"
pkgdesc="A small C program for calculating sunrise and sunset times"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('gcc-libs')
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(glibc)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/risacher/sunwait/archive/refs/tags/$pkgver.tar.gz")
+b2sums=('e623a4d0d05f09ae52671679d84ea6700f667f7629d80873930a36596dd19a9215e4fa62f107172d9e70614077059be6d864d01476651f6c18afa172f64f767d')
-# original version
-#pkgver=20041208
-#source=(http://www.risacher.org/sunwait/$pkgname-$pkgver.tar.gz)
-#md5sums=('957dbcb6d16cb8f3b1ead0687397b495')
-
-# newer fork
-source=("http://downloads.sourceforge.net/project/sunwait4windows/sunwait${_pkgver}.tar")
-md5sums=('97b062fb4adce37d4af59f5b42675fce')
+prepare() {
+ # respect CFLAGS, LDFLAGS
+ sed -i 's/FLAGS=/FLAGS+=/g' $pkgname-$pkgver/makefile
+}
build() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname/$pkgver"
- make
+ make -C $pkgname-$pkgver
}
package() {
- #cd "$srcdir/$pkgname-$pkgver"
- cd "$srcdir/$pkgname/$pkgver"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 $pkgname-$pkgver/$pkgname -t "$pkgdir/usr/bin/"
}
-
-# vim:set ts=2 sw=2 et: