summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-07-23 21:59:47 -0400
committerKyle Keen2015-07-23 21:59:47 -0400
commitca1148fb03ae174462fb5d531708298acf24583f (patch)
tree3e520f99fcca1d71161db9f91b878a16492a0d55
downloadaur-ca1148fb03ae174462fb5d531708298acf24583f.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f4b346a291f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sunwait
+ pkgdesc = A small C program for calculating sunrise and sunset times
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://www.risacher.org/sunwait/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gcc-libs
+ source = http://downloads.sourceforge.net/project/sunwait4windows/sunwait0-8.tar
+ md5sums = 97b062fb4adce37d4af59f5b42675fce
+
+pkgname = sunwait
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51d5b7035bee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Tom Vincent Tom Vincent <http://tlvince.com/contact>
+
+pkgname=sunwait
+pkgver=0.8
+_pkgver=0-8
+pkgrel=1
+url="http://www.risacher.org/sunwait/"
+pkgdesc="A small C program for calculating sunrise and sunset times"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gcc-libs')
+
+# original version
+#pkgver=20041208
+#source=(http://www.risacher.org/sunwait/$pkgname-$pkgver.tar.gz)
+#md5sums=('957dbcb6d16cb8f3b1ead0687397b495')
+
+# newer fork
+source=("http://downloads.sourceforge.net/project/sunwait4windows/sunwait${_pkgver}.tar")
+md5sums=('97b062fb4adce37d4af59f5b42675fce')
+
+build() {
+ #cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname/$pkgver"
+ make
+}
+
+package() {
+ #cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname/$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: