summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Aschenbrenner2017-02-27 23:44:03 -0500
committerVojtech Aschenbrenner2017-02-27 23:44:03 -0500
commita9f191f1f4c122dd45db3f86247f6e5f5b78cbbf (patch)
treeb5c85306623b17f819eec7684804f9e131d0e941
parent1c2eb27c11f72248356c2d7189f047536632b38f (diff)
downloadaur-a9f191f1f4c122dd45db3f86247f6e5f5b78cbbf.tar.gz
Switch to quark-zju fork which works with ruby 2.4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae50af0a0f38..f9900b67b64d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jan 6 11:05:03 UTC 2016
pkgbase = sup-git
pkgdesc = Sup is a console-based email client for people with a lot of email. Great mutt alternative.
- pkgver = 2721.7989b5b
+ pkgver = 2840.93df79b
pkgrel = 1
url = http://supmua.org/
arch = any
@@ -20,7 +18,7 @@ pkgbase = sup-git
depends = ruby-xapian-ruby
optdepends = ruby-gpgme: PGP support
conflicts = sup
- source = sup::git://github.com/sup-heliotrope/sup.git#branch=develop
+ source = sup::git://github.com/quark-zju/sup.git#branch=forked
sha256sums = SKIP
pkgname = sup-git
diff --git a/PKGBUILD b/PKGBUILD
index 5b78982ca95e..4fd3c0342041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Vojtěch Aschenbrenner <v@asch.cz>
_gitname=sup
-_gitbranch=develop
+_gitbranch=forked
pkgname=sup-git
-pkgver=2721.7989b5b
+pkgver=2840.93df79b
pkgrel=1
pkgdesc="Sup is a console-based email client for people with a lot of email. Great mutt alternative."
arch=(any)
@@ -13,7 +13,7 @@ depends=('ruby-chronic-old' 'ruby-highline' 'ruby-locale' 'ruby-lockfile' 'ruby-
optdepends=('ruby-gpgme: PGP support')
makedepends=('git')
conflicts=(sup)
-source=("${_gitname}::git://github.com/sup-heliotrope/${_gitname}.git#branch=${_gitbranch}")
+source=("${_gitname}::git://github.com/quark-zju/${_gitname}.git#branch=${_gitbranch}")
sha256sums=('SKIP')
pkgver() {
@@ -23,6 +23,7 @@ pkgver() {
package() {
cd "$srcdir/$_gitname"
+ sed -i'' -e '7 c s.version = ENV["REL"] || "999"' ${_gitname}.gemspec
gem build ${_gitname}.gemspec
# _gemdir is defined inside package() because if ruby[gems] is not installed on