summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-20 18:57:00 +0800
committerzxp198210052023-12-20 18:57:00 +0800
commit2a21ddc9d01f30904f75c55d046d46b60257c4dc (patch)
tree3727a1f9eeb57041b0efddb85480fdca9c721df4
parentbc4dfff28ce2631b7305797f35ab43fe46312893 (diff)
downloadaur-2a21ddc9d01f30904f75c55d046d46b60257c4dc.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--supalive.sh21
3 files changed, 29 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 702b2585386b..a4a78d3c9590 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = supalive-bin
pkgdesc = Aplicativo para alertas interativos em streaming, integrado com YouTube, Twitch e LivePix.
pkgver = 0.0.35
- pkgrel = 1
+ pkgrel = 2
url = https://supalive.app/
arch = x86_64
license = MIT
@@ -10,10 +10,10 @@ pkgbase = supalive-bin
provides = supalive=0.0.35
conflicts = supalive
source = supalive-0.0.35.deb::https://github.com/SupaLive/supalive/releases/download/v0.0.35/supalive_0.0.35_amd64.deb
- source = LICENSE.md::https://raw.githubusercontent.com/SupaLive/supalive/v0.0.35/LICENSE.md
+ source = LICENSE-0.0.35.md::https://raw.githubusercontent.com/SupaLive/supalive/v0.0.35/LICENSE.md
source = supalive.sh
sha256sums = bea7e2dc17fe742e896006d8dd1fe24e7c7d4d1d95df21d28454f2f818ad4c40
sha256sums = ce9191ae1267b0c88407a86c56917e6d9776ea5b5a7590addc65063faa9e9df9
- sha256sums = 44791f429ff760718ed851c2b0190cec1b5fce3166cbd420309ee0824b51eb61
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
pkgname = supalive-bin
diff --git a/PKGBUILD b/PKGBUILD
index 99a1fe365255..c8b15d11b589 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,32 @@
pkgname=supalive-bin
_pkgname=Supalive
pkgver=0.0.35
-pkgrel=1
+_electronversion=27
+pkgrel=2
pkgdesc="Aplicativo para alertas interativos em streaming, integrado com YouTube, Twitch e LivePix."
arch=("x86_64")
url="https://supalive.app/"
-_githuburl="https://github.com/SupaLive/supalive"
+_ghurl="https://github.com/SupaLive/supalive"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron27'
+ "electron${_electronversion}"
'hicolor-icon-theme'
)
source=(
- "${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
- "LICENSE.md::https://raw.githubusercontent.com/SupaLive/supalive/v${pkgver}/LICENSE.md"
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "LICENSE-${pkgver}.md::https://raw.githubusercontent.com/SupaLive/supalive/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh"
)
sha256sums=('bea7e2dc17fe742e896006d8dd1fe24e7c7d4d1d95df21d28454f2f818ad4c40'
'ce9191ae1267b0c88407a86c56917e6d9776ea5b5a7590addc65063faa9e9df9'
- '44791f429ff760718ed851c2b0190cec1b5fce3166cbd420309ee0824b51eb61')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed -e "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin} --no-sandbox|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
@@ -35,5 +40,5 @@ package() {
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
- install -Dm644 "${srcdir}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
} \ No newline at end of file
diff --git a/supalive.sh b/supalive.sh
index 7856795f29a3..c77c53567639 100644
--- a/supalive.sh
+++ b/supalive.sh
@@ -1,10 +1,17 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron27
-APPDIR="/usr/lib/supalive"
-export PATH="${APPDIR}:${PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file