summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2021-02-22 20:58:56 +0100
committerAntoine Viallon2021-02-22 20:58:56 +0100
commit952a05e7b04ac4d425d929698c1cf289655d96da (patch)
treec2b404881b34d14ebcfebbffb4dd286ce9e7cab7
downloadaur-952a05e7b04ac4d425d929698c1cf289655d96da.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
-rwxr-xr-xsuper-slomo4
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15e3c879f0e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = super-slomo-git
+ pkgdesc = PyTorch implementation of "Super SloMo: High Quality Estimation of Multiple Intermediate Frames for Video Interpolation"
+ pkgver = r65.2ebebc7
+ pkgrel = 1
+ url = https://github.com/avinashpaliwal/Super-SloMo
+ arch = x86_64
+ license = MIT
+ depends = python-torchvision
+ source = super-slomo-git::git+https://github.com/aviallon/Super-SloMo.git#branch=dev
+ source = https://ftp.lesviallon.fr/other/SuperSloMo.ckpt
+ source = super-slomo
+ sha256sums = SKIP
+ sha256sums = 1931f099a99e5e65a563f9b3aae0e04b6d87d09a0c85be1f761185c6bc67506e
+ sha256sums = f8d6878dd33fd37cdb0748a1d556de307f4e9b3469af722c6ab7997d63cfaaaa
+
+pkgname = super-slomo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8eb5221d20a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Antoine Viallon <antoine+aur@lesviallon.fr>
+pkgname=super-slomo-git
+_pkgname=super-slomo
+pkgver=r65.2ebebc7
+pkgrel=1
+license=('MIT')
+pkgdesc='PyTorch implementation of "Super SloMo: High Quality Estimation of Multiple Intermediate Frames for Video Interpolation"'
+depends=("python-torchvision")
+arch=("x86_64")
+url='https://github.com/avinashpaliwal/Super-SloMo'
+source=("$pkgname::git+https://github.com/aviallon/Super-SloMo.git#branch=dev"
+ "https://ftp.lesviallon.fr/other/SuperSloMo.ckpt"
+ "super-slomo")
+sha256sums=('SKIP'
+ '1931f099a99e5e65a563f9b3aae0e04b6d87d09a0c85be1f761185c6bc67506e'
+ 'f8d6878dd33fd37cdb0748a1d556de307f4e9b3469af722c6ab7997d63cfaaaa')
+
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ for patch in $(cd $srcdir && ls *.patch); do
+ patch --verbose -p1 < "$srcdir/$patch"
+ done
+}
+
+package() {
+ cd "$pkgname"
+
+ install -v -Dm644 "$srcdir/SuperSloMo.ckpt" "$pkgdir"/usr/share/"$_pkgname"/model/SuperSloMo.ckpt
+
+ for file in "$srcdir/$pkgname/"*.py; do
+ install -v -Dm644 "$file" "$pkgdir"/usr/share/"$_pkgname"/
+ done
+
+ install -v -Dm755 "$srcdir/super-slomo" "$pkgdir"/usr/bin/super-slomo
+}
diff --git a/super-slomo b/super-slomo
new file mode 100755
index 000000000000..1f7cc8b50ae8
--- /dev/null
+++ b/super-slomo
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+export PYTHONPATH="/usr/share/super-slomo/:$PYTHONPATH"
+exec python /usr/share/super-slomo/video_to_slomo.py --checkpoint /usr/share/super-slomo/model/SuperSloMo.ckpt "$@"