summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Frankenau2017-10-06 09:03:31 +0200
committerJohannes Frankenau2017-10-06 09:05:19 +0200
commit949a9280a41d6c9a70801ecdf2bbf00e355889d1 (patch)
tree3566655a10dbd7fa6c5f373ba6acf48119accb0d
parentafcc17772d8b55a537b3f80ed2ab00e75b0e1ab3 (diff)
downloadaur-949a9280a41d6c9a70801ecdf2bbf00e355889d1.tar.gz
Do no try to create statically linked libraries
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9284ff6b4eb6..8e48054fb397 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = super-user-spark
pkgdesc = Configure your dotfile deployment with a DSL
pkgver = 0.3.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NorfairKing/super-user-spark
arch = i686
arch = x86_64
license = MIT
makedepends = ghc
+ depends = ghc-libs
depends = haskell-aeson
depends = haskell-aeson-pretty
depends = haskell-mtl
diff --git a/PKGBUILD b/PKGBUILD
index 58d9de1e7c86..5c94e6252499 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
pkgname=super-user-spark
pkgver=0.3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Configure your dotfile deployment with a DSL"
url="https://github.com/NorfairKing/super-user-spark"
license=('MIT')
arch=('i686' 'x86_64')
-depends=('haskell-aeson' 'haskell-aeson-pretty' 'haskell-mtl' 'haskell-optparse-applicative' 'haskell-parsec' 'haskell-puremd5' 'haskell-shelly' 'haskell-text')
+depends=('ghc-libs' 'haskell-aeson' 'haskell-aeson-pretty' 'haskell-mtl' 'haskell-optparse-applicative' 'haskell-parsec' 'haskell-puremd5' 'haskell-shelly' 'haskell-text')
makedepends=('ghc')
source=("https://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha512sums=('af92140fdf84fc53f13a1def9b8fc38d682560d4cec6391d53850982678515433efc8dcb46233a8aa995261550de174bd161bb9ba1e92fb572572c153dcade44')
@@ -13,14 +13,16 @@ sha512sums=('af92140fdf84fc53f13a1def9b8fc38d682560d4cec6391d53850982678515433ef
prepare() {
sed -e 's/aeson *>= 0.8 *&& < 1.1/aeson >= 0.8 \&\& < 1.3/' \
-e 's/directory *>= 1.2.5 *&& < 1.3/directory >= 1.2.5 \&\& < 1.4/' \
+ -e 's/optparse-applicative *>= 0.11 *&& < 0.14/optparse-applicative >= 0.11 \&\& < 0.15/' \
+ -e 's/process *>= 1.2 *&& < 1.5/process >= 1.2 \&\& < 1.7/' \
-i $pkgname-$pkgver/$pkgname.cabal
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup register --gen-script
@@ -37,7 +39,4 @@ package() {
runhaskell Setup copy --destdir="${pkgdir}"
install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
-
- # Remove static libs
- find "$pkgdir"/usr/lib -name "*.a" -delete
}