summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael2023-09-15 14:03:48 -0400
committerMichael2023-09-15 14:03:48 -0400
commit50b5daff2ccb0ec39b2d435ebbed9668050502a1 (patch)
treee9bdb890bfd7bb9bcb0f3167cacfbbc70f56e524
parenta3e73fbc864902d045ef5150d96c23c681581c86 (diff)
downloadaur-50b5daff2ccb0ec39b2d435ebbed9668050502a1.tar.gz
Simplified and updated PKGBUILD
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51a2fdd988bc..bf8c539d9198 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,6 @@ pkgbase = supercell-wx-bin
depends = xcb-util-cursor
depends = mesa
provides = supercell-wx
- conflicts = supercell-wx-unstable
conflicts = supercell-wx
source = https://github.com/dpaulat/supercell-wx/releases/download/v0.2.2-release/supercell-wx-linux-x64-v0.2.2.tar.gz
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index fb0b2868c719..ed6db6269514 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Michael Christoff <wxfanatic@gmail.com>
+# Developer: Dan Paulat
pkgname=supercell-wx-bin
pkgver=0.2.2
@@ -10,7 +11,7 @@ license=('MIT')
makedepends=('jq' 'unzip')
depends=('xcb-util' 'xcb-util-cursor' 'mesa')
provides=("supercell-wx")
-conflicts=('supercell-wx-unstable' 'supercell-wx')
+conflicts=('supercell-wx')
source=("https://github.com/dpaulat/supercell-wx/releases/download/v${pkgver}-release/supercell-wx-linux-x64-v${pkgver}.tar.gz")
md5sums=('SKIP')
@@ -28,14 +29,6 @@ package() {
return 1
fi
- # Rename the existing binary
- mv "${srcdir}/supercell-wx/bin/supercell-wx" "${srcdir}/supercell-wx/bin/supercell-wx-bin"
-
- # Create a new script that sets LD_LIBRARY_PATH
- echo '#!/bin/bash' > "${srcdir}/supercell-wx/bin/supercell-wx"
- echo 'LD_LIBRARY_PATH=/opt/supercell-wx/lib:$LD_LIBRARY_PATH /opt/supercell-wx/bin/supercell-wx-bin "$@"' >> "${srcdir}/supercell-wx/bin/supercell-wx"
- chmod +x "${srcdir}/supercell-wx/bin/supercell-wx"
-
# Ensure the destination directory exists
mkdir -p "${pkgdir}/opt/supercell-wx"
@@ -45,4 +38,5 @@ package() {
# Create a symlink in /usr/bin for the new executable script
mkdir -p "${pkgdir}/usr/bin"
ln -s "/opt/supercell-wx/bin/supercell-wx" "${pkgdir}/usr/bin/supercell-wx"
+
}