summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2018-09-29 23:13:50 +0200
committerDavid Runge2018-09-29 23:13:50 +0200
commitd85738ebbea8e6e1577aba19a3ace70842b3f61e (patch)
tree56ebfc1afd1847f640c43c25a436f37d0047c378
parentab56da8491fc57e2362376bdbe1fa7498006749e (diff)
downloadaur-d85738ebbea8e6e1577aba19a3ace70842b3f61e.tar.gz
Incorporating fix for building with boost 1.68.0. Using (soon to be merged) upstream patch for boost >= 1.67.0. Cleaning up cmake options.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD98
-rw-r--r--boost-1.67.patch12
3 files changed, 59 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e1d46aebe13..75b4e06bfd34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = supercollider-git
pkgdesc = Environment and programming language for real time audio synthesis and algorithmic composition
- pkgver = 3.9.3.r783.g88621c5f91
+ pkgver = 3.10.0.beta2.r175.gf5efaffea1
pkgrel = 1
url = https://supercollider.github.io/
arch = i686
@@ -14,30 +14,32 @@ pkgbase = supercollider-git
makedepends = git
makedepends = qt5-tools
depends = boost-libs
+ depends = desktop-file-utils
depends = fftw
depends = jack
- depends = qt5-webengine
depends = qt5-svg
+ depends = qt5-webengine
+ depends = qt5-websockets
depends = yaml-cpp
optdepends = emacs: emacs interface
optdepends = gedit: gedit interface
optdepends = sc3-plugins: additional extension plugins for scsynth
provides = supercollider
conflicts = supercollider
- source = git+https://github.com/supercollider/supercollider.git
+ source = git+https://github.com/supercollider/supercollider.git#branch=develop
source = git+https://github.com/timblechmann/nova-simd.git
source = git+https://github.com/timblechmann/nova-tt.git
source = git+https://github.com/supercollider/hidapi.git
source = git+https://github.com/supercollider/portaudio.git
source = git+https://github.com/supercollider/yaml-cpp.git
- source = boost-1.67.patch
+ source = boost-1.67.patch::https://github.com/dvzrv/supercollider/commit/bbcd068659ced596402dedc78f49fabfab6470bd.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 9980d77802f18fd56d2a13f24f070e81768d9111b2cc63e479a0e9b405a04aec28bc523e5d36aab0462af6a3831d64598470cdc6c3266431e2ca64aa427a6bf2
+ sha512sums = 1bb70a544425d9c3a4e650315fea4a0a388214f1e5b1f300c1bd6706d2fab9e4fe103020c279b8b954386d45fcb5bfd64e730dbf158d4e317517fce3bb393a7c
pkgname = supercollider-git
diff --git a/PKGBUILD b/PKGBUILD
index 4343081fcd7b..fcd669378f15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,33 @@
pkgname=supercollider-git
_name="supercollider"
-pkgver=3.9.3.r783.g88621c5f91
+pkgver=3.10.0.beta2.r175.gf5efaffea1
pkgrel=1
pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://supercollider.github.io/"
license=('GPL3')
-depends=('boost-libs' 'fftw' 'jack' 'qt5-webengine' 'qt5-svg' 'yaml-cpp')
+depends=('boost-libs' 'desktop-file-utils' 'fftw' 'jack' 'qt5-svg' 'qt5-webengine' 'qt5-websockets' 'yaml-cpp')
makedepends=('boost' 'cmake' 'emacs' 'git' 'qt5-tools')
optdepends=('emacs: emacs interface'
'gedit: gedit interface'
'sc3-plugins: additional extension plugins for scsynth')
conflicts=('supercollider')
provides=('supercollider')
-source=("git+https://github.com/${_name}/${_name}.git"
+source=("git+https://github.com/${_name}/${_name}.git#branch=develop"
"git+https://github.com/timblechmann/nova-simd.git"
"git+https://github.com/timblechmann/nova-tt.git"
"git+https://github.com/${_name}/hidapi.git"
"git+https://github.com/${_name}/portaudio.git"
"git+https://github.com/${_name}/yaml-cpp.git"
- 'boost-1.67.patch')
+ 'boost-1.67.patch::https://github.com/dvzrv/supercollider/commit/bbcd068659ced596402dedc78f49fabfab6470bd.patch')
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- '9980d77802f18fd56d2a13f24f070e81768d9111b2cc63e479a0e9b405a04aec28bc523e5d36aab0462af6a3831d64598470cdc6c3266431e2ca64aa427a6bf2')
+ '1bb70a544425d9c3a4e650315fea4a0a388214f1e5b1f300c1bd6706d2fab9e4fe103020c279b8b954386d45fcb5bfd64e730dbf158d4e317517fce3bb393a7c')
pkgver() {
cd "${_name}"
@@ -45,65 +45,71 @@ prepare() {
git config submodule.external_libraries/portaudio_sc_org.branch "${_name}"
git config submodule.external_libraries/yaml-cpp.url "${srcdir}/yaml-cpp"
git submodule update
+ # fix supernova linking with boost >= 1.67.0
+ # https://github.com/supercollider/supercollider/issues/3981
patch -Np1 -i ../boost-1.67.patch
+ # make sure system boost is used:
+ # https://github.com/supercollider/supercollider/issues/4096
+ rm -r external_libraries/boost
mkdir -p build
}
build() {
cd "${_name}/build"
_carch=$(uname -m)
-# Qt5LinguistTools_DIR="/usr/lib/cmake/Qt5LinguistTools"
-# export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
echo "$_carch architecture detected."
case "$_carch" in
"armv6l")
export CC="gcc"
export CXX="g++"
- cmake .. -L \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_TESTING=OFF \
- -DSSE=OFF \
- -DSSE2=OFF \
- -DSUPERNOVA=OFF \
- -DNOVA_SIMD=ON \
- -DNATIVE=OFF \
- -DSC_QT=OFF \
- -DSC_WII=OFF \
- -DSC_ED=OFF \
- -DSC_IDE=OFF \
- -DSC_EL=ON \
- -DCMAKE_C_FLAGS="-march=armv6 -mfpu=vfp -mfloat-abi=hard" \
- -DCMAKE_CXX_FLAGS="-march=armv6 -mfpu=vfp -mfloat-abi=hard"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIBSCSYNTH=ON \
+ -DFORTIFY=ON \
+ -DSC_VIM=OFF \
+ -DSYSTEM_BOOST=ON \
+ -DSYSTEM_YAMLCPP=ON \
+ -DSSE=OFF \
+ -DSSE2=OFF \
+ -DSUPERNOVA=OFF \
+ -DNATIVE=OFF \
+ -DSC_QT=OFF \
+ -DSC_ED=OFF \
+ -DSC_IDE=OFF \
+ -DCMAKE_C_FLAGS='-march=armv6 -mfpu=vfp -mfloat-abi=hard' \
+ -DCMAKE_CXX_FLAGS='-march=armv6 -mfpu=vfp -mfloat-abi=hard' \
+ ..
;;
"armv7l")
export CC="gcc"
export CXX="g++"
- cmake .. -L \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_TESTING=OFF \
- -DSSE=OFF \
- -DSSE2=OFF \
- -DSUPERNOVA=OFF\
- -DNOVA_SIMD=ON \
- -DNATIVE=OFF \
- -DSC_QT=OFF \
- -DSC_WII=OFF \
- -DSC_ED=OFF \
- -DSC_IDE=OFF \
- -DSC_EL=ON \
- -DCMAKE_C_FLAGS="-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon" \
- -DCMAKE_CXX_FLAGS="-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIBSCSYNTH=ON \
+ -DFORTIFY=ON \
+ -DSC_VIM=OFF \
+ -DSYSTEM_BOOST=ON \
+ -DSYSTEM_YAMLCPP=ON \
+ -DSSE=OFF \
+ -DSSE2=OFF \
+ -DSUPERNOVA=OFF \
+ -DNATIVE=OFF \
+ -DSC_QT=OFF \
+ -DSC_ED=OFF \
+ -DSC_IDE=OFF \
+ -DCMAKE_C_FLAGS='-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon' \
+ -DCMAKE_CXX_FLAGS='-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon' \
+ ..
;;
*)
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIBSCSYNTH=ON \
- -DFORTIFY=ON \
- -DSC_VIM=OFF \
- -DSYSTEM_BOOST=ON \
- -DSYSTEM_YAMLCPP=ON \
- -DCMAKE_BUILD_TYPE=Release
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIBSCSYNTH=ON \
+ -DFORTIFY=ON \
+ -DSC_VIM=OFF \
+ -DSYSTEM_BOOST=ON \
+ -DSYSTEM_YAMLCPP=ON \
+ ..
;;
esac
make
diff --git a/boost-1.67.patch b/boost-1.67.patch
deleted file mode 100644
index 1d1abaf91f6e..000000000000
--- a/boost-1.67.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -upr supercollider-3.9.3.orig/server/supernova/utilities/time_tag.hpp supercollider-3.9.3/server/supernova/utilities/time_tag.hpp
---- supercollider-3.9.3.orig/server/supernova/utilities/time_tag.hpp 2018-03-28 23:05:07.000000000 +0300
-+++ supercollider-3.9.3/server/supernova/utilities/time_tag.hpp 2018-06-03 01:32:16.824417338 +0300
-@@ -230,7 +230,7 @@ public:
- #ifdef BOOST_DATE_TIME_POSIX_TIME_STD_CONFIG
- time_duration offset = seconds(get_secs() - ntp_offset) + nanoseconds(get_nanoseconds());
- #else
-- time_duration offset = seconds(get_secs() - ntp_offset) + microseconds(get_nanoseconds()/1000);
-+ time_duration offset = seconds(get_secs() - ntp_offset) + microseconds(long(get_nanoseconds()/1000));
- #endif
- return ptime(base, offset);
- }