summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMads Kjeldgaard2021-06-04 16:24:35 +0200
committerMads Kjeldgaard2021-06-04 16:24:35 +0200
commit579af1b9d7ad2449ab0cc785dc64d7541ae6ab50 (patch)
tree936cc88dc93b83d2371682a6e2214870551e8799
downloadaur-579af1b9d7ad2449ab0cc785dc64d7541ae6ab50.tar.gz
first
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37af7b008bcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = supercollider-simplexnoise-git
+ pkgdesc = SuperCollider implementation of Simplex noise
+ pkgver = r6.6fb3235
+ pkgrel = 1
+ url = https://github.com/esluyter/simplexsynth
+ arch = any
+ groups = pro-audio
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = supercollider
+ source = supercollider-simplexnoise-git-r6.6fb3235::git+https://github.com/esluyter/simplexsynth.git
+ source = supercollider-source::git+https://github.com/supercollider/supercollider.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = supercollider-simplexnoise-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca166055b033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Mads Kjeldgaard<mail@madskjeldgaard.dk>
+pkgname=supercollider-simplexnoise-git
+pkgver=r6.6fb3235
+pkgrel=1
+pkgdesc='SuperCollider implementation of Simplex noise'
+arch=('any')
+url='https://github.com/esluyter/simplexsynth'
+license=('GPL')
+groups=('pro-audio')
+depends=('supercollider')
+makedepends=('git' 'cmake')
+optdepends=()
+source=("$pkgname-$pkgver"::git+$url.git
+ 'supercollider-source::git+https://github.com/supercollider/supercollider.git')
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ SC_SRC="$srcdir/supercollider-source"
+
+ cd $SC_SRC
+ git submodule update --init --recursive
+ cd "$srcdir/$pkgname-$pkgver"
+
+ mkdir build
+ cd build
+
+ cmake -DSC_PATH=$SC_SRC -DCMAKE_BUILD_TYPE=RELEASE ..
+ make
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ DEST="$pkgdir/usr/share/SuperCollider/Extensions/$pkgname"
+
+ # Prepare install directories
+ mkdir -p $DEST/Classes
+ mkdir -p $DEST/HelpSource/Classes
+
+ # Classes
+ PLUGIN_NAME=SimplexSynth
+ PLUGIN_FOLDER=plugins/$PLUGIN_NAME
+ for FILE in "${PLUGIN_FOLDER}/*.sc"; do install -Dm755 ./$FILE "$DEST/Classes"; done
+
+ # Shared objects
+ for FILE in *.so; do install -Dm755 ./build/*.so "$DEST"; done
+
+ # Help Files
+ for FILE in "${PLUGIN_FOLDER}/*.schelp"; do install -Dm755 ./$FILE "$DEST/HelpSource/Classes"; done
+
+}
+