summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Nikiforov2019-04-10 19:57:58 +0300
committerKonstantin Nikiforov2019-04-10 19:57:58 +0300
commit22947e84238aa265e6b7f946bd639020536952be (patch)
tree73671b1c63c187fe8d42acf103e5c907e1d6cd9e
downloadaur-22947e84238aa265e6b7f946bd639020536952be.tar.gz
initial. works.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..338aa85b11d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = supercronic-git
+ pkgdesc = Supercronic is a crontab-compatible job runner, designed specifically to run in containers.
+ pkgver = r83.41d5ac6
+ pkgrel = 1
+ url = https://github.com/aptible/supercronic
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ arch = arm
+ license = MIT
+ makedepends = git
+ makedepends = go
+ makedepends = dep
+ provides = supercronic
+ conflicts = supercronic
+ source = supercronic-git::git+https://github.com/aptible/supercronic
+ sha256sums = SKIP
+
+pkgname = supercronic-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5166d88d4493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=supercronic-git
+__gitroot=github.com/aptible/supercronic
+pkgver=r83.41d5ac6
+pkgrel=1
+pkgdesc="Supercronic is a crontab-compatible job runner, designed specifically to run in containers."
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
+url="https://github.com/aptible/supercronic"
+license=('MIT')
+makedepends=('git' 'go' 'dep')
+provides=('supercronic')
+conflicts=('supercronic')
+_gourl=$__gitroot
+source=("$pkgname::git+https://${__gitroot}")
+sha256sums=('SKIP')
+
+build() {
+ GOPATH="$srcdir" go get -v -d ${_gourl}
+ cd "$srcdir/src/${__gitroot}"
+ GOPATH="$srcdir" dep ensure -vendor-only
+ GOPATH="$srcdir" go build -v
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ install -p -m755 "$srcdir/src/${__gitroot}/supercronic" "$pkgdir/usr/bin/"
+}
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# vim:set ts=2 sw=2 et: