summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2022-07-27 04:29:47 +1200
committerVaporeon2022-07-27 04:29:47 +1200
commita2e92b15085da41646de6e4a24ffe284dff9d5bd (patch)
tree63344160b59384c3f7fb3aef0764b57ba242f9c8
parentb9e0ab9bdceafcd21763e9a1d5d2092f820d4238 (diff)
downloadaur-a2e92b15085da41646de6e4a24ffe284dff9d5bd.tar.gz
Remove unneeded patch.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fe2fd3ce951..2ad7a280c637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = superdux-git
pkgdesc = A Qt-based interface of SameBoy, An accuracy-focused Game Boy/Game Boy Color emulator (git build)
- pkgver = 0.1.0.r359.d1cadf5+r1875.1b38e8c9
+ pkgver = 0.1.0.r360.244c0f0+r1952.859ff795
pkgrel = 1
url = https://github.com/SnowyMouse/superdux
arch = x86_64
@@ -15,9 +15,7 @@ pkgbase = superdux-git
conflicts = superdux
source = git+https://github.com/SnowyMouse/superdux.git
source = git+https://github.com/LIJI32/SameBoy.git
- source = fix_on_vblank_args.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = bc7795e263452d7e215986fd11e6aa47f967cdb7acce5b9e2c7de5e5e66e553a
pkgname = superdux-git
diff --git a/PKGBUILD b/PKGBUILD
index c2957a72c4fa..27767d22b92d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vaporeon <vaporeon@vaporeon.io>
pkgname=superdux-git
-pkgver=0.1.0.r359.d1cadf5+r1875.1b38e8c9
+pkgver=0.1.0.r360.244c0f0+r1952.859ff795
pkgrel=1
pkgdesc="A Qt-based interface of SameBoy, An accuracy-focused Game Boy/Game Boy Color emulator (git build)"
depends=('qt6-base')
@@ -10,11 +10,9 @@ arch=('x86_64')
url="https://github.com/SnowyMouse/superdux"
license=('GPL3')
source=("git+https://github.com/SnowyMouse/${pkgname%-git}.git"
- "git+https://github.com/LIJI32/SameBoy.git"
- 'fix_on_vblank_args.patch')
+ "git+https://github.com/LIJI32/SameBoy.git")
sha256sums=('SKIP'
- 'SKIP'
- 'bc7795e263452d7e215986fd11e6aa47f967cdb7acce5b9e2c7de5e5e66e553a')
+ 'SKIP')
provides=('superdux')
conflicts=('superdux')
@@ -26,22 +24,15 @@ pkgver() {
printf "0.1.0.r%s+r%s" $_superduxver $_sameboyver
}
-prepare() {
- mkdir -p build
- cd ${pkgname%-git}
- patch -Np1 <../fix_on_vblank_args.patch
-}
-
build() {
- cd "$srcdir"/build
- cmake ../${pkgname%-git} -G Ninja \
+ cmake -S ${pkgname%-git} -B build -G Ninja \
-DSAMEBOY_SOURCE_DIR="${srcdir}"/SameBoy \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
- ninja
+
+ cmake --build build
}
package() {
- cd "${srcdir}"/build
- ninja install
+ cmake --install build
}