summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Pieters2021-09-22 20:33:00 +0100
committerYuri Pieters2021-09-22 20:33:00 +0100
commit2ae1ee9a9bf9b5fba6d9f3cf347c4d778b84b369 (patch)
tree1c71be45bb82ba9d29c6d30efbfb681e05139f38
downloadaur-2ae1ee9a9bf9b5fba6d9f3cf347c4d778b84b369.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe67b5041a6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = supergfxctl-git
+ pkgdesc = A utility for Linux graphics switching on Intel/AMD iGPU + nVidia dGPU laptops
+ pkgver = 2.0.1.r6.2c22e67
+ pkgrel = 1
+ url = https://gitlab.com/asus-linux/supergfxctl
+ arch = x86_64
+ license = MPL2
+ makedepends = git
+ makedepends = cargo
+ depends = dbus
+ depends = systemd
+ provides = supergfxctl
+ conflicts = supergfxctl
+ source = git+https://gitlab.com/asus-linux/supergfxctl.git
+ sha256sums = SKIP
+
+pkgname = supergfxctl-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ee529eb792f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Yuri Pieters <magejohnyjtp@gmail.com>
+
+_pkgname=supergfxctl
+pkgname="$_pkgname-git"
+pkgver=2.0.1.r6.2c22e67
+pkgrel=1
+pkgdesc="A utility for Linux graphics switching on Intel/AMD iGPU + nVidia dGPU laptops"
+arch=('x86_64')
+url="https://gitlab.com/asus-linux/$_pkgname"
+license=('MPL2')
+depends=('dbus' 'systemd')
+optdepends=()
+makedepends=('git' 'cargo')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}" || exit
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "${_pkgname}" || exit
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${_pkgname}" || exit
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --features cli,daemon
+}
+
+package() {
+ cd "${_pkgname}" || exit
+ make DESTDIR="${pkgdir}" install
+}