summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAryan Ghasemi2024-04-15 14:53:52 +0330
committerAryan Ghasemi2024-04-15 14:53:52 +0330
commitfd1036ff372195f258fca73952fb57933b71b521 (patch)
tree89cb49d200407f4b6b51a07a887def04206c131b
downloadaur-fd1036ff372195f258fca73952fb57933b71b521.tar.gz
first commit
-rw-r--r--PKGBUILD42
-rw-r--r--icons.tar.gzbin0 -> 3048 bytes
-rw-r--r--supermariowar.install23
3 files changed, 65 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a410abd407b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: Mátyás Mustoha
+# Maintainer: Aryan Ghasemi <gnuphile at telegram>
+
+pkgname='supermariowar-bin'
+_pkgname='supermariowar'
+pkgdesc="Super Mario War multiplayer game."
+pkgver='2024.04.01'
+_pkgver="${pkgver//./-}"
+pkgrel=1
+arch=('x86_64')
+url='https://github.com/mmatyas/supermariowar'
+license=('GPL')
+depends=('sdl2_image' 'sdl2_mixer' 'sdl2' 'zlib')
+makedepends=('zip' 'tar')
+provides=('smw' 'smw-server' 'smw-leveledit' 'smw-worldedit')
+conflicts=('smw-git')
+source=(
+"${_pkgname}-${pkgver}.zip::${url}/releases/download/continuous/${_pkgname}_${_pkgver}_linux.zip"
+"icons.tar.gz"
+)
+install="${_pkgname}.install"
+noextract=( 'icons.tar.gz' )
+sha256sums=('ab5acfc76da18d15bf203ff520cd05e420302e5286e2ed430e7a2c50c5f6813a'
+ 'd92e0c1390e45a09f5c3a56d23d44cd6723cd4cb81fefac33a783acc79301bbc')
+
+package() {
+ cd "$_pkgname"
+
+#documentation and how-to-play
+ install -D -m644 readme-v1.8.html "${pkgdir}/usr/share/doc/smw/readme-v1.8.html"
+
+#game data
+ mkdir -p "${pkgdir}/var/lib/${_pkgname}/"
+ cp -r data/* "${pkgdir}/var/lib/${_pkgname}/"
+
+#binaries
+ install -D -m755 smw smw-leveledit smw-server smw-worldedit -t "${pkgdir}/usr/bin/"
+
+#icons and .desktop files
+ tar xf "${srcdir}/icons.tar.gz" -C "${pkgdir}"
+}
+
diff --git a/icons.tar.gz b/icons.tar.gz
new file mode 100644
index 000000000000..afbdf6ddd9f4
--- /dev/null
+++ b/icons.tar.gz
Binary files differ
diff --git a/supermariowar.install b/supermariowar.install
new file mode 100644
index 000000000000..347bcc4c0e69
--- /dev/null
+++ b/supermariowar.install
@@ -0,0 +1,23 @@
+post_install() {
+ cat <<EOF
+ ##################################
+ Super Mario War successfully installed.
+ Run the game using the .desktop files
+ in /usr/share/applications directory,
+ OR with command bellow:
+ /usr/bin/smw --datadir /var/lib/supermariowar
+ ##################################
+EOF
+}
+
+post_upgrade() {
+ cat <<EOF
+ ##################################
+ Super Mario War successfully installed.
+ Run the game using the .desktop files
+ in /usr/share/applications directory,
+ OR with command bellow:
+ /usr/bin/smw --datadir /var/lib/supermariowar
+ ##################################
+EOF
+}