summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDouglas McFadzean2015-06-08 12:08:38 +0100
committerDouglas McFadzean2015-06-08 12:08:38 +0100
commit28fad16930e39bd1f16c2dd220fabba05e73367c (patch)
tree24a452f55adb45f8e055f49ac769d16c7a10dc8d
downloadaur-28fad16930e39bd1f16c2dd220fabba05e73367c.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3e47711a840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = supermenu
+ pkgdesc = A dynamic and extendible menu-driven program launcher, using dmenu
+ pkgver = 8.2.0
+ pkgrel = 3
+ url = http://mcfadzean.org.uk/appstogo/linux.html#supermenu
+ arch = any
+ license = MIT
+ depends = dmenu
+ optdepends = gksu
+ optdepends = gxmessage
+ optdepends = wine
+ backup = etc/supermenu.conf
+ source = http://mcfadzean.org.uk/appstogo/dl/supermenu/supermenu-8.2.0.tar.gz
+ md5sums = 57def6382d9bd3b77ed22c5982be4185
+
+pkgname = supermenu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cff8f31907b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: ninian <mcfadzean.org.uk ta linux>
+
+pkgname=supermenu
+pkgver=8.2.0
+pkgrel=3
+pkgdesc="A dynamic and extendible menu-driven program launcher, using dmenu"
+arch=('any')
+url="http://mcfadzean.org.uk/appstogo/linux.html#supermenu"
+license=('MIT')
+depends=('dmenu')
+optdepends=('gksu' 'gxmessage' 'wine')
+backup=('etc/supermenu.conf')
+source=("http://mcfadzean.org.uk/appstogo/dl/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('57def6382d9bd3b77ed22c5982be4185')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # script
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+
+ # configuration
+ install -Dm644 $pkgname.conf "$pkgdir/etc/$pkgname.conf"
+ msg "Remember to customize $pkgname.conf after installation"
+
+ # licensing
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}