summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarl.george2015-07-10 08:25:39 -0500
committercarl.george2015-07-10 08:25:39 -0500
commita04e81723106e59d54054edd772c6850728475a1 (patch)
treed18d650ec8e50a83c8bf89bbc82404d098925bdd
parentad0e4011f252e43e628fd3bd350c91535ad5915d (diff)
downloadaur-a04e81723106e59d54054edd772c6850728475a1.tar.gz
1.0.8-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--completion-fix.patch23
3 files changed, 9 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeffb2aaf74c..fe785112f459 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = supernova
pkgdesc = Use novaclient with multiple OpenStack nova environments the easy way
- pkgver = 1.0.7
- pkgrel = 8
+ pkgver = 1.0.8
+ pkgrel = 1
url = https://github.com/major/supernova
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/major/supernova/archive/v1.0.7.tar.gz
+ source = https://github.com/major/supernova/archive/v1.0.8.tar.gz
source = nova2-executable.patch
- source = completion-fix.patch
- sha256sums = e0336590e8b4a73404acbfd7379285c631daf628baaba64c9f42d839982d9949
+ sha256sums = 5abc13e44ca1eeeb7626fe133a104fec19ec5663ea3b7077af8874cb70b7baad
sha256sums = 688de41b2ab9f050b210b30ab24b6bf86bb40cb387eb8ef6a6816a79edb7b195
- sha256sums = dd7a1222aba71da8a0d6a8290a4e4b9f9b37bcdf44dc71e58f16fe6dc9320b36
pkgname = supernova
depends = python-novaclient
diff --git a/PKGBUILD b/PKGBUILD
index 01f61a7b59f2..3cb08aa01802 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,19 @@ _name="supernova"
_cmd="${_name}"
pkgname=("supernova" "supernova2")
-pkgver="1.0.7"
-pkgrel="8"
+pkgver="1.0.8"
+pkgrel="1"
pkgdesc="Use novaclient with multiple OpenStack nova environments the easy way"
arch=("any")
url="https://github.com/major/${_name}"
license=("Apache")
makedepends=("python-setuptools" "python2-setuptools")
source=("${url}/archive/v${pkgver}.tar.gz"
- "nova2-executable.patch"
- "completion-fix.patch")
-sha256sums=('e0336590e8b4a73404acbfd7379285c631daf628baaba64c9f42d839982d9949'
- '688de41b2ab9f050b210b30ab24b6bf86bb40cb387eb8ef6a6816a79edb7b195'
- 'dd7a1222aba71da8a0d6a8290a4e4b9f9b37bcdf44dc71e58f16fe6dc9320b36')
+ "nova2-executable.patch")
+sha256sums=('5abc13e44ca1eeeb7626fe133a104fec19ec5663ea3b7077af8874cb70b7baad'
+ '688de41b2ab9f050b210b30ab24b6bf86bb40cb387eb8ef6a6816a79edb7b195')
prepare() {
- patch -d "${srcdir}/${_name}-${pkgver}" -p1 < completion-fix.patch
cp -a "${srcdir}/${_name}-${pkgver}"{,-python2}
patch -d "${srcdir}/${_name}-${pkgver}-python2" -p1 < nova2-executable.patch
}
diff --git a/completion-fix.patch b/completion-fix.patch
deleted file mode 100644
index 6dad220caf5c..000000000000
--- a/completion-fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 387d664802ee24ad90d8f72f840863e2e6b34dc0 Mon Sep 17 00:00:00 2001
-From: cgtx <carl@carlgeorge.us>
-Date: Thu, 18 Dec 2014 13:29:21 -0600
-Subject: [PATCH] parse all configs for environment completion (fix #70)
-
----
- contrib/supernova-completion.bash | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/contrib/supernova-completion.bash b/contrib/supernova-completion.bash
-index 8757c9a..e50be36 100644
---- a/contrib/supernova-completion.bash
-+++ b/contrib/supernova-completion.bash
-@@ -3,7 +3,8 @@
- _supernova()
- {
- local cur=${COMP_WORDS[COMP_CWORD]}
-- local possibilities=$(awk '/\[/{ gsub(/\[|\]/,"");print}' ~/.supernova)
-+ local configs=$(cat "${XDG_CONFIG_HOME}"/supernova ~/.supernova ./.supernova 2> /dev/null)
-+ local possibilities=$(echo "${configs}" | sed -n '/^\[.*\]/ s_\[\(.*\)\]_\1_p' | sort -u)
- COMPREPLY=( $(compgen -W "${possibilities}" -- $cur) )
- }
- complete -F _supernova supernova