summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarl.george2015-07-22 19:25:51 -0500
committercarl.george2015-07-22 19:25:51 -0500
commitb4a38356bde9fb6a1871fe17429ab56c25a21239 (patch)
treec952f2a4231e37c1923e320499b3a5bd38212b89
parent8096643dab3c3c5d42f463adde1024b40ac78365 (diff)
downloadaur-b4a38356bde9fb6a1871fe17429ab56c25a21239.tar.gz
2.0.2-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--nova2-executable.patch8
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51f8d5d7e014..90e9f66b5d8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = supernova
pkgdesc = Use novaclient with multiple OpenStack nova environments the easy way
- pkgver = 2.0.0
+ pkgver = 2.0.2
pkgrel = 1
url = https://github.com/major/supernova
arch = any
license = Apache
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/major/supernova/archive/v2.0.0.tar.gz
+ source = https://github.com/major/supernova/archive/v2.0.2.tar.gz
source = nova2-executable.patch
- sha256sums = 43b27ee9ed2ca7b0b5860bf52422750e215b60cb71eca106a57b4f900faef24e
- sha256sums = cd2d47ce9d9b949844c5e58ed7a1b32cb2367fd7c4429ec0d971fd24bd544704
+ sha256sums = d096a677261226dca7884f6a181a81224939f97259ca43534d2078a68913f650
+ sha256sums = bd05ce5bc154df2b53fbf4e6fad6c90808ef62df6100427d50e503c4df129e04
pkgname = supernova
depends = python-click
diff --git a/PKGBUILD b/PKGBUILD
index 0374f39b8898..3cc689c3c264 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name="supernova"
_cmd="${_name}"
pkgname=("supernova" "supernova2")
-pkgver="2.0.0"
+pkgver="2.0.2"
pkgrel="1"
pkgdesc="Use novaclient with multiple OpenStack nova environments the easy way"
arch=("any")
@@ -13,8 +13,8 @@ license=("Apache")
makedepends=("python-setuptools" "python2-setuptools")
source=("${url}/archive/v${pkgver}.tar.gz"
"nova2-executable.patch")
-sha256sums=('43b27ee9ed2ca7b0b5860bf52422750e215b60cb71eca106a57b4f900faef24e'
- 'cd2d47ce9d9b949844c5e58ed7a1b32cb2367fd7c4429ec0d971fd24bd544704')
+sha256sums=('d096a677261226dca7884f6a181a81224939f97259ca43534d2078a68913f650'
+ 'bd05ce5bc154df2b53fbf4e6fad6c90808ef62df6100427d50e503c4df129e04')
prepare() {
cp -a "${srcdir}/${_name}-${pkgver}"{,-python2}
diff --git a/nova2-executable.patch b/nova2-executable.patch
index cb643c7ccb3f..ab9a9953eff6 100644
--- a/nova2-executable.patch
+++ b/nova2-executable.patch
@@ -1,10 +1,10 @@
diff -Naurp a/supernova/executable.py b/supernova/executable.py
---- a/supernova/executable.py 2015-07-18 00:22:07.000000000 -0500
-+++ b/supernova/executable.py 2015-07-18 21:58:23.018328979 -0500
-@@ -57,7 +57,7 @@ def print_env_list(ctx, param, value):
+--- a/supernova/executable.py 2015-07-21 16:11:04.000000000 -0500
++++ b/supernova/executable.py 2015-07-22 19:24:20.782381530 -0500
+@@ -66,7 +66,7 @@ command_settings = {
- @click.command()
+ @click.command(context_settings=command_settings)
-@click.option('--executable', '-x', default='nova',
+@click.option('--executable', '-x', default='nova2',
help='Command to run', show_default=True)