summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2022-12-16 23:05:25 -0500
committerTed Alff2022-12-16 23:05:25 -0500
commit6ae9e71a44444dd7603f468ecafccbe71007bd9b (patch)
tree5fa604e705b1786fc8687b8c77e23da07507129c
parent98058bb23c2d9f5a5a5c5f9f6ec8dba2432347c5 (diff)
downloadaur-6ae9e71a44444dd7603f468ecafccbe71007bd9b.tar.gz
Version bump 2.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
-rw-r--r--rename_system_hotkey_dep.patch12
3 files changed, 31 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bde948d30b1..7df6698dcc64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = superpaper
pkgdesc = Cross-platform multi monitor wallpaper manager
- pkgver = 2.1.0+32+g7d0b284
- pkgrel = 2
+ pkgver = 2.2.0
+ pkgrel = 1
url = https://github.com/hhannine/Superpaper
arch = any
license = MIT
@@ -13,10 +13,12 @@ pkgbase = superpaper
depends = python-pillow>=7.0
depends = python-screeninfo>=0.6.1
depends = python-wxpython
- depends = python-system_hotkey>=1.0.2+10+9541587
+ depends = python-system_hotkey>=1.0.5
depends = python-xpybutil
depends = python-numpy
- source = superpaper::git+https://github.com/hhannine/Superpaper#commit=7d0b28400cccafa57f7a43ca2342d73c3293ff92
- sha256sums = SKIP
+ source = superpaper-2.2.0.tar.gz::https://github.com/hhannine/Superpaper/archive/v2.2.0.tar.gz
+ source = rename_system_hotkey_dep.patch
+ sha256sums = 22781b33c8fc72b69df467a0998f28d6fd5bfe6c4f8ad4794e46d80fde0b1537
+ sha256sums = 02bc7fb70c18c7292ee9cdac9be58e0954cdb03b07032ee9b5c567fe5ec4d5a5
pkgname = superpaper
diff --git a/PKGBUILD b/PKGBUILD
index a8297e8f0499..d68092783b1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=superpaper
-pkgver=2.1.0+32+g7d0b284
-pkgrel=2
+pkgver=2.2.0
+pkgrel=1
pkgdesc="Cross-platform multi monitor wallpaper manager"
arch=('any')
url="https://github.com/hhannine/Superpaper"
license=('MIT')
depends=('python-pillow>=7.0' 'python-screeninfo>=0.6.1' 'python-wxpython'
- 'python-system_hotkey>=1.0.2+10+9541587' 'python-xpybutil' 'python-numpy')
+ 'python-system_hotkey>=1.0.5' 'python-xpybutil' 'python-numpy')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools' 'git')
-_commit='7d0b28400cccafa57f7a43ca2342d73c3293ff92'
-source=("${pkgname}::git+https://github.com/hhannine/${pkgname^}#commit=${_commit}")
-sha256sums=('SKIP')
-#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz")
-#sha256sums=('1de27ea76b77731c6a6e0221450cd3913a2275399c553ae7c13557ca7c2f5c08')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hhannine/${pkgname^}/archive/v${pkgver}.tar.gz"
+ 'rename_system_hotkey_dep.patch')
+sha256sums=('22781b33c8fc72b69df467a0998f28d6fd5bfe6c4f8ad4794e46d80fde0b1537'
+ '02bc7fb70c18c7292ee9cdac9be58e0954cdb03b07032ee9b5c567fe5ec4d5a5')
-pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed -r "s/^v//;s/-/+/g"
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np2 -r- -i ../rename_system_hotkey_dep.patch
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}-${pkgver}"
python -m build -wn
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}-${pkgver}"
python -m installer -d "${pkgdir}" dist/*.whl
}
diff --git a/rename_system_hotkey_dep.patch b/rename_system_hotkey_dep.patch
new file mode 100644
index 000000000000..1db9374fec49
--- /dev/null
+++ b/rename_system_hotkey_dep.patch
@@ -0,0 +1,12 @@
+diff -Naur ./superpaper-2.2.0.orig/setup.py ./superpaper-2.2.0/setup.py
+--- ./superpaper-2.2.0.orig/setup.py 2022-12-16 22:57:49.982911108 -0500
++++ ./superpaper-2.2.0/setup.py 2022-12-16 22:58:05.160926679 -0500
+@@ -61,7 +61,7 @@
+ "Pillow>=7.0.0",
+ "screeninfo>=0.6.1",
+ "numpy>=1.18.0",
+- "system_hotkey310>=1.0.5",
++ "system_hotkey>=1.0.5",
+ "xcffib>=0.8.0",
+ "xpybutil>=0.0.5"
+ ],