summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Valecillos2020-10-26 11:24:13 +0100
committerJose Valecillos2020-10-26 11:24:13 +0100
commitba62c30e14a1d44a6966a7d8b497eb25931f2a90 (patch)
tree0da185efe87e71bac872fdd66a2fc6a626105fe6
parenta0e72721e6415593b14adf38e618bbd5a70d2d6e (diff)
downloadaur-ba62c30e14a1d44a6966a7d8b497eb25931f2a90.tar.gz
Bump to 6.0.1 and changes in building
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9634fa1e5718..400569c9963a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = superproductivity-git
pkgdesc = To Do List / Time Tracker with Jira Integration.
- pkgver = 5.1.2.r1.g70cd2a8e
+ pkgver = 6.0.1.r2.g15c734304
pkgrel = 1
url = http://super-productivity.com/
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = superproductivity-git
depends = xprintidle
depends = libnotify
depends = libappindicator-gtk3
- depends = electron
+ depends = electron>=10
provides = superproductivity
conflicts = superproductivity
source = super-productivity::git+https://github.com/johannesjo/super-productivity
diff --git a/PKGBUILD b/PKGBUILD
index 613790aa91fd..b13fb7458a39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=superproductivity-git
_pkgname=superproductivity
_reponame=super-productivity
-pkgver=5.4.2.r0.gb77473a6
+pkgver=6.0.1.r2.g15c734304
pkgrel=1
pkgdesc='To Do List / Time Tracker with Jira Integration.'
arch=('x86_64')
url="http://super-productivity.com/"
license=('MIT')
depends=('alsa-lib' 'gtk3' 'gconf' 'libxss' 'libxtst' 'nss' 'nspr'
-'xdg-utils' 'xprintidle' 'libnotify' 'libappindicator-gtk3' 'electron')
+'xdg-utils' 'xprintidle' 'libnotify' 'libappindicator-gtk3' 'electron>=10')
makedepends=('git' 'npm' 'yarn' 'python')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -64,12 +64,11 @@ build() {
electronDist=$(dirname $(realpath $(which electron)))
electronVer=$(electron --version | tail -c +2)
- # Building angular
- node --max_old_space_size=4096 ./node_modules/@angular/cli/bin/ng build --aot --prod --base-href=''
- # Building electron-builder
- yarn electron:build && yarn electron-builder
+ # Building angular and electron-builder
+ yarn buildFrontend:prod && yarn electron:build
+
# Building the app
- npx electron-builder --linux dir --x64 --dir dist \
+ npx electron-builder --linux dir --x64 --dir \
-c.electronDist="${electronDist}" -c.electronVersion="${electronVer}"
}