summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182022-02-03 12:16:57 +0100
committerLukas18182022-02-03 12:16:57 +0100
commit25e4c52a869b96a0b39a740552cfb5b3c7e1d506 (patch)
tree11fe0fdb84624b930fe5afb423ef2d98af3b382b
parentf03fa319693173fda248fc76e3735f23588636ab (diff)
downloadaur-25e4c52a869b96a0b39a740552cfb5b3c7e1d506.tar.gz
read $MAKEFLAGS; adjust needed cereal version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76a01056e9e6..ff6e0faf2be2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = superslicer
arch = x86_64
license = AGPL3
makedepends = boost>=1.73.0
- makedepends = cereal>=1.3.1
+ makedepends = cereal>=1.3.0
makedepends = cmake
makedepends = eigen
makedepends = libigl
diff --git a/PKGBUILD b/PKGBUILD
index c4e655643362..5581c14e4712 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://github.com/supermerill/SuperSlicer"
license=('AGPL3')
options=(!emptydirs)
depends=('boost-libs>=1.73.0' 'cgal' 'glew' 'nlopt' 'imath' 'openvdb' 'qhull>=2020.2-4' 'wxgtk3-dev-314-opt')
-makedepends=('boost>=1.73.0' 'cereal>=1.3.1' 'cmake' 'eigen' 'libigl' 'ninja' 'openvdb' 'wxgtk2-dev-314-opt') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
+makedepends=('boost>=1.73.0' 'cereal>=1.3.0' 'cmake' 'eigen' 'libigl' 'ninja' 'openvdb' 'wxgtk2-dev-314-opt') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
optdepends=('superslicer-profiles: Predefined printer profiles')
replaces=('slic3r++')
source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
@@ -64,7 +64,12 @@ build()
-DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev-314/bin/wx-config \
-DCMAKE_CXX_FLAGS="-Wno-unused-command-line-argument -Wl,-rpath=/opt/wxgtk-dev-314/lib"
- ninja
+ if [[ "$MAKEFLAGS" =~ -j[0123456789]+ ]] # get max parallel job from $MAKEFLAGS
+ then
+ ninja_flags="${BASH_REMATCH[0]}"
+ fi
+ echo "ninja ${ninja_flags:=}"
+ ninja ${ninja_flags:=} # ninja dose not support environment variable, see: https://github.com/ninja-build/ninja/issues/1482
}
package()