summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182020-12-31 15:55:52 +0100
committerLukas18182020-12-31 15:55:52 +0100
commita0a631cdb237848ba40953aa51140217d160acba (patch)
treed0eb7dd97b000136210582f130379a2086d000c7
parent58885d430834e104ec3b35a3566d5ac8c1541961 (diff)
downloadaur-a0a631cdb237848ba40953aa51140217d160acba.tar.gz
change back to the official boost package
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Replace-deprecated-Boost-header-in-admesh.patch63
-rw-r--r--PKGBUILD18
-rw-r--r--start-superslicer.sh2
4 files changed, 77 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83a8bd7ba72d..1139a8c98128 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = superslicer
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
pkgver = 2.2.54.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/supermerill/SuperSlicer
arch = x86_64
license = AGPL3
@@ -16,17 +16,19 @@ pkgbase = superslicer
depends = nlopt
depends = openvdb
depends = wxgtk3-dev-opt
- depends = boost-libs-171-opt
+ depends = boost>=1.73.0
depends = qhull>=2020.2-4
replaces = slic3r++
source = https://github.com/supermerill//SuperSlicer/archive/2.2.54.2.tar.gz
source = superslicer.desktop
source = start-superslicer.sh
source = 0001-wxgtk3-is-broken-on-wayland.patch
+ source = 0001-Replace-deprecated-Boost-header-in-admesh.patch
sha512sums = 3e28d28f463be49217d4aa19691bd190d644f86474786db69ec82d58090d2231a6c0add66eec59ac9f8c2169bfcd730a0c9deafd9df48182e92194bf6d2f39b6
sha512sums = 8f75de56ba3e29b9c650d2946bd11afcf406a7fd42d2620ec44e4e76f6b64626de720190ce0f8be29ba7c48f714bfa0a71c45f868bdce7bc1ac7dbbc0e9e7583
- sha512sums = 3703901d97ae1982a36eb5c491fe0fd6953e81e6bb1d155404acfcac1de1f377931c88b9667688775af5ed16bd46944ca3a285bc4b2739762faa70e546044c43
+ sha512sums = abfbd056be518b1b733cddef6c430cc3c4199d5df13067574dd3269cf35b798e11b43f55f1dfb57d6d8ee1da06882825fef0f7a170a9b069b95e9aea1ec8f31d
sha512sums = acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5
+ sha512sums = 9a860dbac69ca7a195ef43cb2b80a8b5cf2c34bddb91867aa8ba16bbb754ab68c4baf57fa7e2562f96facc435c64ed8445505edb152382dbc5106a509136a2c8
pkgname = superslicer
diff --git a/0001-Replace-deprecated-Boost-header-in-admesh.patch b/0001-Replace-deprecated-Boost-header-in-admesh.patch
new file mode 100644
index 000000000000..bea239bfadcb
--- /dev/null
+++ b/0001-Replace-deprecated-Boost-header-in-admesh.patch
@@ -0,0 +1,63 @@
+From 3a194f91871684b5fc8c6c78300b87e0ee1cb610 Mon Sep 17 00:00:00 2001
+From: Megidd <megiddgit@gmail.com>
+Date: Mon, 21 Sep 2020 18:00:52 +0330
+Subject: [PATCH] Replace deprecated Boost header in "admesh"
+
+---
+ src/admesh/stlinit.cpp | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/admesh/stlinit.cpp b/src/admesh/stlinit.cpp
+index 390fe56a4..6aa2c4417 100644
+--- a/src/admesh/stlinit.cpp
++++ b/src/admesh/stlinit.cpp
+@@ -28,7 +28,7 @@
+
+ #include <boost/log/trivial.hpp>
+ #include <boost/nowide/cstdio.hpp>
+-#include <boost/detail/endian.hpp>
++#include <boost/predef/other/endian.h>
+
+ #include "stl.h"
+
+@@ -36,9 +36,9 @@
+ #error "SEEK_SET not defined"
+ #endif
+
+-#ifndef BOOST_LITTLE_ENDIAN
++#if BOOST_ENDIAN_BIG_BYTE
+ extern void stl_internal_reverse_quads(char *buf, size_t cnt);
+-#endif /* BOOST_LITTLE_ENDIAN */
++#endif /* BOOST_ENDIAN_BIG_BYTE */
+
+ static FILE* stl_open_count_facets(stl_file *stl, const char *file)
+ {
+@@ -89,10 +89,10 @@ static FILE* stl_open_count_facets(stl_file *stl, const char *file)
+ // Read the int following the header. This should contain # of facets.
+ uint32_t header_num_facets;
+ bool header_num_faces_read = fread(&header_num_facets, sizeof(uint32_t), 1, fp) != 0;
+-#ifndef BOOST_LITTLE_ENDIAN
++#if BOOST_ENDIAN_BIG_BYTE
+ // Convert from little endian to big endian.
+ stl_internal_reverse_quads((char*)&header_num_facets, 4);
+-#endif /* BOOST_LITTLE_ENDIAN */
++#endif /* BOOST_ENDIAN_BIG_BYTE */
+ if (! header_num_faces_read || num_facets != header_num_facets)
+ BOOST_LOG_TRIVIAL(info) << "stl_open_count_facets: Warning: File size doesn't match number of facets in the header: " << file;
+ }
+@@ -158,10 +158,10 @@ static bool stl_read(stl_file *stl, FILE *fp, int first_facet, bool first)
+ // Read a single facet from a binary .STL file. We assume little-endian architecture!
+ if (fread(&facet, 1, SIZEOF_STL_FACET, fp) != SIZEOF_STL_FACET)
+ return false;
+-#ifndef BOOST_LITTLE_ENDIAN
++#if BOOST_ENDIAN_BIG_BYTE
+ // Convert the loaded little endian data to big endian.
+ stl_internal_reverse_quads((char*)&facet, 48);
+-#endif /* BOOST_LITTLE_ENDIAN */
++#endif /* BOOST_ENDIAN_BIG_BYTE */
+ } else {
+ // Read a single facet from an ASCII .STL file
+ // skip solid/endsolid
+--
+2.29.2
+
diff --git a/PKGBUILD b/PKGBUILD
index a05f133a57c6..fa5e09bd565a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,24 @@
pkgname=superslicer
pkgver=2.2.54.2
_pkgtag=$pkgver
-pkgrel=2
+pkgrel=3
pkgdesc="G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)"
arch=('x86_64')
url="https://github.com/supermerill/SuperSlicer"
license=('AGPL3')
-depends=('cgal' 'glew' 'nlopt' 'openvdb' 'wxgtk3-dev-opt' 'boost-libs-171-opt' 'qhull>=2020.2-4')
+depends=('cgal' 'glew' 'nlopt' 'openvdb' 'wxgtk3-dev-opt' 'boost>=1.73.0' 'qhull>=2020.2-4')
replaces=('slic3r++')
makedepends=('cereal' 'cmake' 'eigen' 'libigl' 'openvdb' 'wxgtk2-dev-opt') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
"superslicer.desktop"
"start-superslicer.sh"
- "0001-wxgtk3-is-broken-on-wayland.patch")
+ "0001-wxgtk3-is-broken-on-wayland.patch"
+ "0001-Replace-deprecated-Boost-header-in-admesh.patch")
sha512sums=('3e28d28f463be49217d4aa19691bd190d644f86474786db69ec82d58090d2231a6c0add66eec59ac9f8c2169bfcd730a0c9deafd9df48182e92194bf6d2f39b6'
'8f75de56ba3e29b9c650d2946bd11afcf406a7fd42d2620ec44e4e76f6b64626de720190ce0f8be29ba7c48f714bfa0a71c45f868bdce7bc1ac7dbbc0e9e7583'
- '3703901d97ae1982a36eb5c491fe0fd6953e81e6bb1d155404acfcac1de1f377931c88b9667688775af5ed16bd46944ca3a285bc4b2739762faa70e546044c43'
- 'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5')
+ 'abfbd056be518b1b733cddef6c430cc3c4199d5df13067574dd3269cf35b798e11b43f55f1dfb57d6d8ee1da06882825fef0f7a170a9b069b95e9aea1ec8f31d'
+ 'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5'
+ '9a860dbac69ca7a195ef43cb2b80a8b5cf2c34bddb91867aa8ba16bbb754ab68c4baf57fa7e2562f96facc435c64ed8445505edb152382dbc5106a509136a2c8')
prepare()
{
@@ -29,6 +31,7 @@ prepare()
# apply patches
patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch"
+ patch --forward --strip=1 --input="$srcdir/0001-Replace-deprecated-Boost-header-in-admesh.patch"
}
build()
@@ -46,11 +49,6 @@ build()
-DSLIC3R_WX_STABLE=ON \
-DSLIC3R_GTK=3 \
-DSLIC3R_BUILD_TESTS=OFF \
- -DBoost_NO_BOOST_CMAKE=TRUE \
- -DBoost_NO_SYSTEM_PATHS=TRUE \
- -DBOOST_ROOT:PATHNAME=/opt/usr \
- -DBoost_LIBRARY_DIRS:FILEPATH=/opt/usr/lib \
- -DBoost_INCLUDE_DIR:FILEPATH=/opt/usr/include \
-DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config
make
diff --git a/start-superslicer.sh b/start-superslicer.sh
index d41bb130759c..9c38b060309b 100644
--- a/start-superslicer.sh
+++ b/start-superslicer.sh
@@ -1,2 +1,2 @@
#!/bin/bash
-LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/usr/lib:/opt/wxgtk-dev/lib" /usr/share/SuperSlicer/superslicer $@
+LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/wxgtk-dev/lib" /usr/share/SuperSlicer/superslicer "$@"