summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182021-10-08 18:08:43 +0200
committerLukas18182021-10-08 18:08:43 +0200
commitae2305d088d703c3950f7c2c8597a19f6c12248d (patch)
tree6cdbc6922007af49abdd4c6aa5ebf22f7ca1cb5c
parent826a517bf104fc602a0cc4ca47374432ca929634 (diff)
downloadaur-ae2305d088d703c3950f7c2c8597a19f6c12248d.tar.gz
switch to wxgtk-dev-314 package; remove start script
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--start-superslicer.sh15
3 files changed, 6 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 031c6bbeae0a..afe50c48f925 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = superslicer
pkgdesc = G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
pkgver = 2.3.56.9
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/supermerill/SuperSlicer
arch = x86_64
@@ -20,15 +20,13 @@ pkgbase = superslicer
depends = nlopt
depends = openvdb
depends = qhull>=2020.2-4
- depends = wxgtk3-dev-opt
+ depends = wxgtk3-dev-314-opt
optdepends = superslicer-profiles: Predefined printer profiles
replaces = slic3r++
source = https://github.com/supermerill//SuperSlicer/archive/2.3.56.9.tar.gz
- source = start-superslicer.sh
source = 0001-wxgtk3-is-broken-on-wayland.patch
source = https://raw.githubusercontent.com/archlinux/svntogit-community/1dea61c0b581ff5001d073689f68b0323740be93/trunk/prusa-slicer-openexr3.patch
sha512sums = 05c57765770889dc365eb721a2e6491f16de5a03c03493a682c49b769435d6db6e0ad52c0cfced7aa402dc751e4fdcbfc0623fa82d8431e45a590e64b12b6769
- sha512sums = 8d2874b25547a5daac87ccbb71f529dfd263ccb4e19500538db72cf654f0d00eabafdc24267d763f5649cb085a56cf17bf4f87da9cdeb62e4d0d07d32eb3f9dd
sha512sums = acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5
sha512sums = c33c2414746bc9d7dceb5af59ecb4aed2189211fc3c8b144d712a39d3677ba4d366eb9b4dd05fbc3811954d69cd1273d714dc4536489fe153ac1aee2919e5c98
diff --git a/PKGBUILD b/PKGBUILD
index 7fc82ceeffac..70d60d8b3071 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
pkgname=superslicer
pkgver=2.3.56.9
_pkgtag=$pkgver
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)"
arch=('x86_64')
url="https://github.com/supermerill/SuperSlicer"
license=('AGPL3')
-depends=('boost-libs>=1.73.0' 'cgal' 'glew' 'nlopt' 'openvdb' 'qhull>=2020.2-4' 'wxgtk3-dev-opt')
+depends=('boost-libs>=1.73.0' 'cgal' 'glew' 'nlopt' 'openvdb' 'qhull>=2020.2-4' 'wxgtk3-dev-314-opt')
makedepends=('boost>=1.73.0' 'cereal' 'cmake' 'eigen' 'libigl' 'ninja' 'openvdb' 'wxgtk2-dev-opt') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
optdepends=('superslicer-profiles: Predefined printer profiles')
replaces=('slic3r++')
source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
- "start-superslicer.sh"
"0001-wxgtk3-is-broken-on-wayland.patch"
"https://raw.githubusercontent.com/archlinux/svntogit-community/1dea61c0b581ff5001d073689f68b0323740be93/trunk/prusa-slicer-openexr3.patch")
sha512sums=('05c57765770889dc365eb721a2e6491f16de5a03c03493a682c49b769435d6db6e0ad52c0cfced7aa402dc751e4fdcbfc0623fa82d8431e45a590e64b12b6769'
- '8d2874b25547a5daac87ccbb71f529dfd263ccb4e19500538db72cf654f0d00eabafdc24267d763f5649cb085a56cf17bf4f87da9cdeb62e4d0d07d32eb3f9dd'
'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5'
'c33c2414746bc9d7dceb5af59ecb4aed2189211fc3c8b144d712a39d3677ba4d366eb9b4dd05fbc3811954d69cd1273d714dc4536489fe153ac1aee2919e5c98')
@@ -53,8 +51,8 @@ build()
-DSLIC3R_GTK=3 \
-DSLIC3R_BUILD_TESTS=OFF \
-DSLIC3R_ALPHA=OFF \
- -DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev/bin/wx-config \
- -DCMAKE_CXX_FLAGS="-Wl,-rpath=/opt/wxgtk-dev/lib"
+ -DwxWidgets_CONFIG_EXECUTABLE=/opt/wxgtk-dev-314/bin/wx-config \
+ -DCMAKE_CXX_FLAGS="-Wl,-rpath=/opt/wxgtk-dev-314/lib"
ninja
}
@@ -67,7 +65,4 @@ package()
test ! -h "$pkgdir/usr/share/SuperSlicer/resources" || rm "$pkgdir/usr/share/SuperSlicer/resources"
install -d "$pkgdir/usr/share/applications"
-
- mv "$pkgdir/usr/bin/superslicer" "$pkgdir/usr/share/SuperSlicer"
- install -Dm 755 "${srcdir}/start-superslicer.sh" "${pkgdir}/usr/bin/superslicer"
}
diff --git a/start-superslicer.sh b/start-superslicer.sh
deleted file mode 100644
index d25be0ac349b..000000000000
--- a/start-superslicer.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/bash
-
-import_settings()
-{
- if [ -d "$1" ] && [ ! -d "$HOME/.config/SuperSlicer" ]
- then
- echo "import data from $1 to the new data folder ~/.config/SuperSlicer"
- cp -r "$HOME/.SuperSlicer" "$HOME/.config/SuperSlicer"
- fi
-}
-
-import_settings "$HOME/.SuperSlicer"
-import_settings "$HOME/.config/SuperSlicer-alpha"
-
-/usr/share/SuperSlicer/superslicer "$@"