summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182021-08-13 18:22:38 +0200
committerLukas18182021-08-13 18:22:38 +0200
commit88a9d4c58ff353eb86efc62956323bde5f306930 (patch)
tree384c2604f9a08fb5ca1174fc7cda82b42e605865
downloadaur-88a9d4c58ff353eb86efc62956323bde5f306930.tar.gz
init repo
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0698e052001f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = superslicer-profiles-git
+ pkgdesc = predefinded printer profiles for SuperSlicer
+ pkgver = r16.a95ec3a
+ pkgrel = 1
+ url = https://github.com/slic3r/slic3r-profiles
+ arch = any
+ license = AGPL3
+ makedepends = git
+ provides = superslicer-profiles=:r16.a95ec3a
+ source = slic3r-profiles::git+https://github.com/slic3r/slic3r-profiles.git
+ sha512sums = SKIP
+
+pkgname = superslicer-profiles-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e75ba34e5766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Lukas1818 aur at lukas1818 dot de
+
+pkgname=superslicer-profiles-git
+pkgver=r16.a95ec3a
+pkgrel=1
+pkgdesc="predefinded printer profiles for SuperSlicer"
+arch=('any')
+url="https://github.com/slic3r/slic3r-profiles"
+license=('AGPL3')
+makedepends=('git')
+provides=("superslicer-profiles=$epoch:$pkgver")
+source=("slic3r-profiles::git+https://github.com/slic3r/slic3r-profiles.git")
+sha512sums=('SKIP')
+
+
+pkgver()
+{
+ cd "$srcdir/slic3r-profiles"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ install -d "$pkgdir/usr/share/SuperSlicer/profiles"
+ cp -r "$srcdir/slic3r-profiles" -T "$pkgdir/usr/share/SuperSlicer/profiles"
+ chmod -R 644 "$pkgdir/usr/share/SuperSlicer/profiles"
+ find "$pkgdir/usr/share/SuperSlicer/profiles" -type d -exec chmod 755 {} \;
+}