summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Savard2013-12-29 23:27:41 -0500
committerJulien Savard2015-06-08 12:17:53 -0400
commitb0ecaba282c5c09e93b608c2d50ebfda6adabdb0 (patch)
treeb4b9b7c60cf81863b0eb28e472056ce0af94a546
downloadaur-b0ecaba282c5c09e93b608c2d50ebfda6adabdb0.tar.gz
Import to AUR4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--supersonicball.desktop11
-rw-r--r--supersonicball.sh2
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ff292d7d325
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = supersonicball
+ pkgdesc = The crazy ball tunnel game
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = http://julosoft.net/supersonicball/
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = love
+ source = supersonicball.sh
+ source = supersonicball.desktop
+ source = http://files.julosoft.net/supersonicball-0.9.2.love
+ sha1sums = 4515bad415633fce6174e54a871454c26af1848b
+ sha1sums = 1683f7d1827a28eefc8ff311e8bf59630a4837fc
+ sha1sums = 040f1c841e6147cfc7dfbb37e2494b2933549cfe
+
+pkgname = supersonicball
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0c6c3447a71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Julien Savard <juju2143@gmail.com>
+
+pkgname=supersonicball
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="The crazy ball tunnel game"
+arch=('any')
+url="http://julosoft.net/supersonicball/"
+license=('GPL')
+depends=('love')
+makedepends=('unzip')
+source=(${pkgname}.sh
+ ${pkgname}.desktop
+ http://files.julosoft.net/${pkgname}-${pkgver}.love)
+sha1sums=('4515bad415633fce6174e54a871454c26af1848b'
+ '1683f7d1827a28eefc8ff311e8bf59630a4837fc'
+ '040f1c841e6147cfc7dfbb37e2494b2933549cfe')
+
+build() {
+ unzip -u "${srcdir}/${pkgname}-${pkgver}.love" README.md -d "${srcdir}"
+}
+
+package() {
+ # Install Data
+ install -D -m755 "${srcdir}/${pkgname}-${pkgver}.love" "${pkgdir}/usr/share/${pkgname}/${pkgname}.love"
+ install -D -m644 "${srcdir}/README.md" "$pkgdir/usr/share/${pkgname}/README"
+
+ # Install Launcher
+ install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install Desktop
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/supersonicball.desktop b/supersonicball.desktop
new file mode 100644
index 000000000000..f78307cc629d
--- /dev/null
+++ b/supersonicball.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=0.9.2
+Type=Application
+Icon=gnome-mime-application-x-love-game
+Exec=supersonicball
+Terminal=false
+StartupNotify=false
+Name=Supersonic Ball
+GenericName=Arcade Game
+Comment=The crazy ball tunnel game
+Categories=Game;ArcadeGame;
diff --git a/supersonicball.sh b/supersonicball.sh
new file mode 100644
index 000000000000..e4421f17e3b7
--- /dev/null
+++ b/supersonicball.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+love /usr/share/supersonicball/supersonicball.love