summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-05-11 23:13:57 +0800
committertaotieren2021-05-11 23:13:57 +0800
commitffea08feb53007019501bca43a97125460251813 (patch)
tree3aca01da37b332764cea68ec15303dc83c86b7af
downloadaur-ffea08feb53007019501bca43a97125460251813.tar.gz
Update SuperTabbar
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD38
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ce716770876
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = supertabbar-git
+ pkgdesc = SuperTabbar 超级标签栏
+ pkgver = dafb5af
+ pkgrel = 1
+ url = https://gitee.com/Limexb/SuperTabbar
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-virtualkeyboard
+ makedepends = qconf
+ makedepends = qt5-tools
+ makedepends = dtkwidget
+ makedepends = libx11
+ makedepends = dtkgui
+ depends = qt5-virtualkeyboard
+ depends = qconf
+ depends = qt5-tools
+ depends = dtkwidget
+ depends = libx11
+ depends = dtkgui
+ provides = supertabbar-git
+ conflicts = supertabbar-git
+ conflicts = supertabber
+ options = !strip
+ source = SuperTabbar::git+https://gitee.com/Limexb/SuperTabbar.git
+ sha256sums = SKIP
+
+pkgname = supertabbar-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9eebd53de818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+src
+pkg
+SuperTabber
+*.deb
+*.rpm
+*.zip
+*.pkg.tar.xz
+*.pkg.tar.zst
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98fdebeab0c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+_pkgname=SuperTabbar
+pkgname=supertabbar-git
+_softname=supertabbar
+pkgver=dafb5af
+pkgrel=1
+pkgdesc="SuperTabbar 超级标签栏"
+arch=('any')
+url="https://gitee.com/Limexb/SuperTabbar"
+license=('GPL3')
+provides=(${pkgname})
+conflicts=(${pkgname} 'supertabber')
+#replaces=(${pkgname})
+depends=('qt5-virtualkeyboard' 'qconf' 'qt5-tools' 'dtkwidget' 'libx11' 'dtkgui')
+makedepends=('git' 'qt5-virtualkeyboard' 'qconf' 'qt5-tools' 'dtkwidget' 'libx11' 'dtkgui')
+backup=()
+options=('!strip')
+#install=${pkgname}.install
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ qmake && make
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}/${_softname}" "${pkgdir}/usr/bin/${_softname}"
+ install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_softname}/LICENSE"
+ install -Dm644 "${srcdir}/${_pkgname}/debian/top.yzzi.${_softname}.desktop" "${pkgdir}/usr/share/applications/top.yzzi.${_softname}.desktop"
+ install -Dm644 "${srcdir}/${_pkgname}/debian/top.yzzi.${_softname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/mimetypes/top.yzzi.${_softname}.svg"
+}