summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2017-10-24 13:15:02 +0200
committerFrederic Bezies2017-10-24 13:15:02 +0200
commitbf37d136b740d88b2d6e1749c481acb769823714 (patch)
tree82c7fca8afed8c9f8b27aef0f1d6f9037a68f8cc
parent4ea891bcbda900847dd36228c1476035580b06d1 (diff)
downloadaur-bf37d136b740d88b2d6e1749c481acb769823714.tar.gz
PKGBUILD and PGKVER cleanup
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b095f9478254..c01ad571c1c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,33 @@
# Generated by mksrcinfo v8
-# Sun Apr 17 05:59:22 UTC 2016
+# Tue Oct 24 11:14:47 UTC 2017
pkgbase = supertux-git
pkgdesc = A classic 2D jump'n run sidescroller game in a style similar to the original SuperMario game
- pkgver = 7292.f24d3bc
+ pkgver = v0.5.0.r303.g57010ce4f
pkgrel = 1
+ epoch = 1
url = http://supertux.lethargik.org/
arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = cmake
+ makedepends = physfs
+ makedepends = curl
+ makedepends = boost
depends = sdl2_image
- depends = physfs
depends = openal
depends = libvorbis
- depends = curl
- depends = boost
depends = glew
provides = supertux
conflicts = supertux
- source = git+https://github.com/SuperTux/supertux
+ source = git+https://github.com/SuperTux/supertux.git
source = git+https://github.com/SuperTux/data.git
source = git+https://github.com/google/googletest.git
- source = git+https://github.com/SuperTux/physfs
+ source = git+https://github.com/SuperTux/physfs.git
source = git+https://github.com/SuperTux/sexp-cpp.git
source = git+https://github.com/albertodemichelis/squirrel.git
source = git+https://github.com/SuperTux/tinygettext.git
- source = git+https://github.com/SuperTux/translations
+ source = git+https://github.com/SuperTux/translations.git
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index fc0a60b384fc..ec7bd738537a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
-# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
# Original Maintainer: Hakim <acrox999 at gmail dot com>
# Contributor: Patrick Bartels <p4ddy.b@gmail.com>
pkgname=supertux-git
-pkgver=7292.f24d3bc
+_pkgname=supertux
+pkgver=v0.5.0.r303.g57010ce4f
pkgrel=1
+epoch=1
pkgdesc="A classic 2D jump'n run sidescroller game in a style similar to the original SuperMario game"
url='http://supertux.lethargik.org/'
license=(GPL)
arch=(i686 x86_64)
-depends=(sdl2_image physfs openal libvorbis curl boost glew)
-makedepends=(git cmake)
+depends=('sdl2_image' 'openal' 'libvorbis' 'glew')
+makedepends=('git' 'cmake' 'physfs' 'curl' 'boost')
conflicts=(supertux)
provides=(supertux)
-source=('git+https://github.com/SuperTux/supertux'
+source=('git+https://github.com/SuperTux/supertux.git'
# submodules
'git+https://github.com/SuperTux/data.git'
'git+https://github.com/google/googletest.git'
- 'git+https://github.com/SuperTux/physfs'
+ 'git+https://github.com/SuperTux/physfs.git'
'git+https://github.com/SuperTux/sexp-cpp.git'
'git+https://github.com/albertodemichelis/squirrel.git'
'git+https://github.com/SuperTux/tinygettext.git'
- 'git+https://github.com/SuperTux/translations')
+ 'git+https://github.com/SuperTux/translations.git')
sha512sums=('SKIP'
'SKIP'
'SKIP'
@@ -32,12 +35,12 @@ sha512sums=('SKIP'
'SKIP')
pkgver() {
- cd supertux
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd supertux
+ cd "$_pkgname"
git submodule init
git config submodule.data.url "${srcdir}"/data
@@ -54,7 +57,7 @@ prepare() {
}
build() {
- cd supertux
+ cd "$_pkgname"
export CFLAGS+=" -fPIC"
export CXXFLAGS+=" -fPIC"
@@ -68,7 +71,7 @@ build() {
}
package() {
- cd supertux
+ cd "$_pkgname"
make DESTDIR="${pkgdir}/" install
}