summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Sprunk2023-01-08 18:23:47 +0100
committerRobert Sprunk2023-01-08 18:23:47 +0100
commit18445d08df10b53963a44e150038fed1154030db (patch)
treee5f826ea17f7e2e438c67a66583fef74dacad2ae
parentfb11251f22b963e68bc0295728c29824325b80f7 (diff)
downloadaur-18445d08df10b53963a44e150038fed1154030db.tar.gz
Update to version 0.7.3; update zipstream-ng dep
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 428d019957e3..8deaa22f9783 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = supysonic
pkgdesc = A Python implementation of the Subsonic server API.
- pkgver = 0.7.2
+ pkgver = 0.7.3
pkgrel = 1
url = https://github.com/spl0k/supysonic
install = supysonic.install
@@ -10,13 +10,12 @@ pkgbase = supysonic
makedepends = python-setuptools
makedepends = python-pip
depends = python-flask
- depends = python-pony
+ depends = python-peewee
depends = python-pillow
depends = python-requests
- depends = python-mutagen
- depends = python-watchdog
- depends = python-zipstream
depends = python-mediafile
+ depends = python-watchdog
+ depends = python-zipstream-ng
optdepends = ffmpeg: Transcoder support
optdepends = mpv: Jukebox support
optdepends = mariadb: MariaDB database
@@ -25,14 +24,15 @@ pkgbase = supysonic
optdepends = postgresql: PostgreSQL database
optdepends = python-psycopg2: PostgreSQL database support
optdepends = python-waitress: pure-Python WSGI server
+ optdepends = gunicorn: WSGI HTTP Server
backup = etc/supysonic
- source = supysonic-0.7.2.tar.gz::https://github.com/spl0k/supysonic/archive/0.7.2.tar.gz
+ source = supysonic-0.7.3.tar.gz::https://github.com/spl0k/supysonic/archive/0.7.3.tar.gz
source = supysonic.ini
source = supysonic.sysusers
source = supysonic.tmpfiles
source = supysonic-daemon.service
source = supysonic-waitress.service
- sha256sums = f30c8e05a10d286db73f242e5899ec548a189c296687acd88c9f29e296f15647
+ sha256sums = f5047b6a8085180999c3516df4f8e5f0cb8bc5310906e086337d54e9145d6570
sha256sums = e8a10b2be1c3b6757cee8928f2e585351da9e9b6eadfa68c8905913108a26b80
sha256sums = b4b723d30fb45f86a15ec218910cd3935aac4546d5e2f9a1e1bc79cccfb98480
sha256sums = 430eba10de5381a425074b89d0a46fb770be5112b26e81ac6a2b55765675cb13
diff --git a/PKGBUILD b/PKGBUILD
index c2b9a06ea2ca..6125edf17128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Robert Sprunk <arch-aur@sprunk.me>
# Contributor: Bryn Edwards <bryn.edwards@gmail.com>
+# Contributor: trap000d
pkgname=supysonic
-pkgver=0.7.2
+pkgver=0.7.3
pkgrel=1
pkgdesc="A Python implementation of the Subsonic server API."
arch=('any')
@@ -9,13 +10,12 @@ url="https://github.com/spl0k/$pkgname"
license=('AGPL')
depends=(
'python-flask'
- 'python-pony'
+ 'python-peewee'
'python-pillow'
'python-requests'
- 'python-mutagen'
- 'python-watchdog'
- 'python-zipstream'
'python-mediafile'
+ 'python-watchdog'
+ 'python-zipstream-ng'
)
makedepends=(
'git'
@@ -29,14 +29,15 @@ optdepends=('ffmpeg: Transcoder support'
'mod_wsgi: Apache WSGI module'
'postgresql: PostgreSQL database'
'python-psycopg2: PostgreSQL database support'
- 'python-waitress: pure-Python WSGI server')
+ 'python-waitress: pure-Python WSGI server'
+ 'gunicorn: WSGI HTTP Server')
source=("$pkgname-$pkgver.tar.gz::https://github.com/spl0k/$pkgname/archive/$pkgver.tar.gz"
"$pkgname.ini"
"$pkgname.sysusers"
"$pkgname.tmpfiles"
"$pkgname-daemon.service"
"$pkgname-waitress.service")
-sha256sums=('f30c8e05a10d286db73f242e5899ec548a189c296687acd88c9f29e296f15647'
+sha256sums=('f5047b6a8085180999c3516df4f8e5f0cb8bc5310906e086337d54e9145d6570'
'e8a10b2be1c3b6757cee8928f2e585351da9e9b6eadfa68c8905913108a26b80'
'b4b723d30fb45f86a15ec218910cd3935aac4546d5e2f9a1e1bc79cccfb98480'
'430eba10de5381a425074b89d0a46fb770be5112b26e81ac6a2b55765675cb13'