summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2022-02-20 17:42:54 +0100
committerXiretza2022-02-20 17:42:54 +0100
commitb85040d72d614a799ebcbc6dff5840ddb597ccc4 (patch)
treeced43fbc7293d8d38b7c8b6ed44f58a010e158f3
parent3abbdec343506e5737934e87e8b7a37ad83fa7f1 (diff)
downloadaur-b85040d72d614a799ebcbc6dff5840ddb597ccc4.tar.gz
Update patches, dependencies
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Unvendor-dependencies.patch38
-rw-r--r--0002-Don-t-build-hello-worlds.patch16
-rw-r--r--0003-Fix-installation-directories.patch6
-rw-r--r--0004-Fix-install-location-of-cmake-config-files.patch12
-rw-r--r--0005-Build-shared-instead-of-static-library.patch12
-rw-r--r--PKGBUILD26
7 files changed, 68 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 103db6b10f75..3372688bed52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = surelog-git
pkgdesc = SystemVerilog 2017 Pre-processor, Parser, Elaborator, UHDM Compiler.
- pkgver = r3840.a1edc64c1
+ pkgver = r4293.9605843b0
pkgrel = 1
url = https://github.com/chipsalliance/Surelog
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = surelog-git
makedepends = cmake
makedepends = tcl
makedepends = antlr4
+ makedepends = python
depends = antlr4-runtime
depends = uhdm
depends = flatbuffers
- provides = surelog=r3840.a1edc64c1
+ provides = surelog=r4293.9605843b0
conflicts = surelog
source = git+https://github.com/chipsalliance/Surelog
source = 0001-Unvendor-dependencies.patch
@@ -22,10 +23,10 @@ pkgbase = surelog-git
source = 0004-Fix-install-location-of-cmake-config-files.patch
source = 0005-Build-shared-instead-of-static-library.patch
sha256sums = SKIP
- sha256sums = 957d4ac0d8da855d993719ae5a33ee112c01ec62cdf2411f93d945b33e4f246e
- sha256sums = edb38cf4fbed373574e02f2e7559ee8c43ffaf75d6945ff5c0251886d18a9924
- sha256sums = f6ce38895b3f493f45e75fe87b7604d9f0a52b56f38b320d797ba6e4c3d79969
- sha256sums = 4a14d0861cc8daa3fd192711870c02394e2def0ff662c9f846c4baf36f97f6d4
- sha256sums = 968e6832222b9eadce0bc4dc4e0e7872f26bb4bec69709771d1bd4c7b64b22ba
+ sha256sums = a5ccdcb228860b1c20a87a6143a1d4ed32afe3ee246f7585adf1d9854d748aca
+ sha256sums = c0e6fbdff015e076621f8657d7ec4978b3c346c8ae8a17479497d92d8d8d5dd2
+ sha256sums = be218b888bec744b7cd490997908eef32d5efeca02bca986d9dd83c8ca3b24b4
+ sha256sums = c079f04d70faa09ec7dc691549d9d55e924f26649cfab74fa1cdc27792f39420
+ sha256sums = 8dc742b181bc9f7886b8eee2579e3ae50b96d4bebb819c4f27b03db33de538e8
pkgname = surelog-git
diff --git a/0001-Unvendor-dependencies.patch b/0001-Unvendor-dependencies.patch
index 2f602b0d29ee..8b29f41bdb07 100644
--- a/0001-Unvendor-dependencies.patch
+++ b/0001-Unvendor-dependencies.patch
@@ -1,14 +1,14 @@
-From f88522e568690de61a5974d379eb04c6df562709 Mon Sep 17 00:00:00 2001
+From d2145ff63fb36138a2e3d3622b651a52c61378b2 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 5 Dec 2021 17:00:05 +0100
Subject: [PATCH 1/5] Unvendor dependencies
---
- CMakeLists.txt | 32 ++++++--------------------------
- 1 file changed, 6 insertions(+), 26 deletions(-)
+ CMakeLists.txt | 33 ++++++---------------------------
+ 1 file changed, 6 insertions(+), 27 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b19ece004..fff4cfa9d 100644
+index 1fa9e4aa0..e37d9ea00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,14 +28,6 @@ set(CMAKE_CXX_STANDARD 17)
@@ -26,24 +26,24 @@ index b19ece004..fff4cfa9d 100644
# NOTE: Set the global output directories after the subprojects have had their go at it
set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/lib)
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bin)
-@@ -358,13 +350,11 @@ foreach(gen_src ${surelog_generated_SRC})
+@@ -366,13 +358,11 @@ foreach(gen_src ${surelog_generated_SRC})
set_source_files_properties(${gen_src} PROPERTIES GENERATED TRUE)
endforeach()
+find_package(antlr4-runtime REQUIRED)
+
add_library(surelog STATIC ${surelog_SRC} ${surelog_generated_SRC})
- set_target_properties(surelog PROPERTIES PUBLIC_HEADER src/surelog.h)
+ set_target_properties(surelog PROPERTIES PUBLIC_HEADER include/Surelog/surelog.h)
-target_include_directories(surelog PRIVATE
- third_party/antlr4_fast/runtime/Cpp/runtime/src
- third_party/flatbuffers/include
- third_party/googletest/googletest/include
- third_party/googletest/googlemock/include)
+target_include_directories(surelog PRIVATE ${ANTLR4_INCLUDE_DIR})
- target_include_directories(surelog PUBLIC $<INSTALL_INTERFACE:include/surelog>)
+ target_include_directories(surelog PUBLIC $<INSTALL_INTERFACE:include>)
if (SURELOG_WITH_PYTHON)
target_include_directories(surelog PUBLIC ${Python3_INCLUDE_DIRS}) # Keep this at the end
-@@ -407,12 +397,9 @@ if(MSVC OR WIN32)
+@@ -415,12 +405,9 @@ if(MSVC OR WIN32)
endif()
target_link_libraries(surelog-bin PUBLIC surelog)
@@ -57,7 +57,15 @@ index b19ece004..fff4cfa9d 100644
add_dependencies(surelog GenerateParser)
add_dependencies(surelog GenerateSerializer)
-@@ -471,10 +458,8 @@ function(register_gtests)
+@@ -444,7 +431,6 @@ if (UNIX)
+ endif()
+
+ if (CMAKE_SYSTEM_NAME MATCHES "Linux")
+- target_link_libraries(uhdm PRIVATE stdc++fs)
+ target_link_libraries(surelog PRIVATE stdc++fs)
+ target_link_libraries(surelog PRIVATE rt)
+ endif()
+@@ -480,10 +466,8 @@ function(register_gtests)
# Build binary, link all relevant libs and extract tests
add_executable(${test_bin} EXCLUDE_FROM_ALL ${gtest_cc_file})
@@ -69,7 +77,7 @@ index b19ece004..fff4cfa9d 100644
# For simplicity, we link the test with libsurelog, but there is of
# course a lot unnecessary churn if headers are modified.
# Often it is sufficient to just have a few depeendencies.
-@@ -601,15 +586,10 @@ install(
+@@ -613,15 +597,10 @@ install(
TARGETS surelog-bin
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
install(
@@ -77,15 +85,15 @@ index b19ece004..fff4cfa9d 100644
+ TARGETS surelog
EXPORT Surelog
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/surelog
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/surelog)
+ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/Surelog)
-install(
- TARGETS uhdm capnp kj
- EXPORT Surelog
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}/uhdm
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/uhdm)
- install(
- DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/python
- ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sv
+
+ if (SURELOG_WITH_PYTHON)
+ install(
--
-2.34.1
+2.35.1
diff --git a/0002-Don-t-build-hello-worlds.patch b/0002-Don-t-build-hello-worlds.patch
index ba59fdf40e56..2e95311a4c38 100644
--- a/0002-Don-t-build-hello-worlds.patch
+++ b/0002-Don-t-build-hello-worlds.patch
@@ -1,4 +1,4 @@
-From d874ba796f28a8349c872620b0bc3a264794f47d Mon Sep 17 00:00:00 2001
+From c3d924cb76257144fa02dfbc2a9869f63b5d7966 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 5 Dec 2021 19:39:06 +0100
Subject: [PATCH 2/5] Don't build hello worlds
@@ -8,23 +8,23 @@ Subject: [PATCH 2/5] Don't build hello worlds
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index fff4cfa9d..ad96f6c08 100644
+index e37d9ea00..8d5616552 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -381,9 +381,9 @@ if (APPLE)
- endif()
+@@ -388,9 +388,9 @@ if (APPLE)
endif()
+ if (NOT QUICK_COMP)
-add_executable(hellosureworld ${PROJECT_SOURCE_DIR}/src/hellosureworld.cpp)
-add_executable(hellouhdm ${PROJECT_SOURCE_DIR}/src/hellouhdm.cpp)
-add_executable(hellodesign ${PROJECT_SOURCE_DIR}/src/hellodesign.cpp)
+add_executable(hellosureworld EXCLUDE_FROM_ALL ${PROJECT_SOURCE_DIR}/src/hellosureworld.cpp)
+add_executable(hellouhdm EXCLUDE_FROM_ALL ${PROJECT_SOURCE_DIR}/src/hellouhdm.cpp)
+add_executable(hellodesign EXCLUDE_FROM_ALL ${PROJECT_SOURCE_DIR}/src/hellodesign.cpp)
+ endif()
if(MSVC OR WIN32)
- # We have two files named "surelog.lib" and both getting generated in the lib folder
-@@ -551,7 +551,7 @@ else()
+@@ -559,7 +559,7 @@ else()
WORKING_DIRECTORY "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}")
endif()
@@ -33,7 +33,7 @@ index fff4cfa9d..ad96f6c08 100644
add_custom_command(
#TARGET surelog-bin
#POST_BUILD
-@@ -565,7 +565,7 @@ add_custom_command(
+@@ -573,7 +573,7 @@ add_custom_command(
COMMAND echo " Package OVM created"
WORKING_DIRECTORY "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}")
@@ -43,5 +43,5 @@ index fff4cfa9d..ad96f6c08 100644
#TARGET surelog-bin
#POST_BUILD
--
-2.34.1
+2.35.1
diff --git a/0003-Fix-installation-directories.patch b/0003-Fix-installation-directories.patch
index 3a5c13264215..4d61c524f36c 100644
--- a/0003-Fix-installation-directories.patch
+++ b/0003-Fix-installation-directories.patch
@@ -1,4 +1,4 @@
-From f80247d4d065f234b43fbf71b5817f26097a3528 Mon Sep 17 00:00:00 2001
+From 32e3bb00310ecd2c24e3530d304e74924658464a Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 5 Dec 2021 19:56:28 +0100
Subject: [PATCH 3/5] Fix installation directories
@@ -8,7 +8,7 @@ Subject: [PATCH 3/5] Fix installation directories
1 file changed, 2 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ad96f6c08..01f6e275c 100644
+index 8d5616552..791ce4013 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,8 @@ option(
@@ -21,5 +21,5 @@ index ad96f6c08..01f6e275c 100644
cmake_policy(SET CMP0091 NEW)
set(CMAKE_MSVC_RUNTIME_LIBRARY "MultiThreaded$<$<CONFIG:Debug>:Debug>")
--
-2.34.1
+2.35.1
diff --git a/0004-Fix-install-location-of-cmake-config-files.patch b/0004-Fix-install-location-of-cmake-config-files.patch
index 4b75d394e612..141db14625f5 100644
--- a/0004-Fix-install-location-of-cmake-config-files.patch
+++ b/0004-Fix-install-location-of-cmake-config-files.patch
@@ -1,4 +1,4 @@
-From 7daa3a5e17685e9eacb7d2361aaea428f1079d40 Mon Sep 17 00:00:00 2001
+From c93ac13ad8a215852c44fc11005ba77c0dc1ddf6 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 5 Dec 2021 20:08:42 +0100
Subject: [PATCH 4/5] Fix install location of cmake config files
@@ -8,10 +8,10 @@ Subject: [PATCH 4/5] Fix install location of cmake config files
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 01f6e275c..dd13c32b1 100644
+index 791ce4013..b9d7aa5ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -713,21 +713,21 @@ endif()
+@@ -728,21 +728,21 @@ endif()
install(
EXPORT Surelog
FILE Surelog.cmake
@@ -34,8 +34,8 @@ index 01f6e275c..dd13c32b1 100644
- DESTINATION cmake)
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/Surelog)
- ADD_CUSTOM_TARGET(link_target ALL
- COMMAND ${CMAKE_COMMAND} -E create_symlink
+ ADD_CUSTOM_TARGET(
+ link_target ALL
--
-2.34.1
+2.35.1
diff --git a/0005-Build-shared-instead-of-static-library.patch b/0005-Build-shared-instead-of-static-library.patch
index da1f03c9678a..a94159c19282 100644
--- a/0005-Build-shared-instead-of-static-library.patch
+++ b/0005-Build-shared-instead-of-static-library.patch
@@ -1,4 +1,4 @@
-From 8f5e69dafcf211002201587f1721987fc4701846 Mon Sep 17 00:00:00 2001
+From 8f7631564079f56de50beb6c21701e4ce3cc6891 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sun, 5 Dec 2021 20:52:12 +0100
Subject: [PATCH 5/5] Build shared instead of static library
@@ -8,18 +8,18 @@ Subject: [PATCH 5/5] Build shared instead of static library
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dd13c32b1..1b34c44f7 100644
+index b9d7aa5ed..eef1b317f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -354,7 +354,7 @@ endforeach()
+@@ -362,7 +362,7 @@ endforeach()
find_package(antlr4-runtime REQUIRED)
-add_library(surelog STATIC ${surelog_SRC} ${surelog_generated_SRC})
+add_library(surelog SHARED ${surelog_SRC} ${surelog_generated_SRC})
- set_target_properties(surelog PROPERTIES PUBLIC_HEADER src/surelog.h)
+ set_target_properties(surelog PROPERTIES PUBLIC_HEADER include/Surelog/surelog.h)
target_include_directories(surelog PRIVATE ${ANTLR4_INCLUDE_DIR})
- target_include_directories(surelog PUBLIC $<INSTALL_INTERFACE:include/surelog>)
+ target_include_directories(surelog PUBLIC $<INSTALL_INTERFACE:include>)
--
-2.34.1
+2.35.1
diff --git a/PKGBUILD b/PKGBUILD
index 072850a6d62c..0b7934316330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
+# Maintainer: xiretza <aur@xiretza.xyz>
+
_pkgname=Surelog
pkgname=${_pkgname,,}-git
-pkgver=r3840.a1edc64c1
+pkgver=r4293.9605843b0
pkgrel=1
pkgdesc="SystemVerilog 2017 Pre-processor, Parser, Elaborator, UHDM Compiler."
arch=(x86_64)
url="https://github.com/chipsalliance/$_pkgname"
license=('Apache')
depends=('antlr4-runtime' 'uhdm' 'flatbuffers')
-makedepends=('git' 'cmake' 'tcl' 'antlr4')
+makedepends=('git' 'cmake' 'tcl' 'antlr4' 'python')
checkdepends=('gtest')
provides=("${_pkgname,,}=$pkgver")
conflicts=("${_pkgname,,}")
@@ -20,11 +22,11 @@ source=(
"0005-Build-shared-instead-of-static-library.patch"
)
sha256sums=('SKIP'
- '957d4ac0d8da855d993719ae5a33ee112c01ec62cdf2411f93d945b33e4f246e'
- 'edb38cf4fbed373574e02f2e7559ee8c43ffaf75d6945ff5c0251886d18a9924'
- 'f6ce38895b3f493f45e75fe87b7604d9f0a52b56f38b320d797ba6e4c3d79969'
- '4a14d0861cc8daa3fd192711870c02394e2def0ff662c9f846c4baf36f97f6d4'
- '968e6832222b9eadce0bc4dc4e0e7872f26bb4bec69709771d1bd4c7b64b22ba')
+ 'a5ccdcb228860b1c20a87a6143a1d4ed32afe3ee246f7585adf1d9854d748aca'
+ 'c0e6fbdff015e076621f8657d7ec4978b3c346c8ae8a17479497d92d8d8d5dd2'
+ 'be218b888bec744b7cd490997908eef32d5efeca02bca986d9dd83c8ca3b24b4'
+ 'c079f04d70faa09ec7dc691549d9d55e924f26649cfab74fa1cdc27792f39420'
+ '8dc742b181bc9f7886b8eee2579e3ae50b96d4bebb819c4f27b03db33de538e8')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -35,11 +37,11 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- patch -p1 < "$srcdir/0001-Unvendor-dependencies.patch"
- patch -p1 < "$srcdir/0002-Don-t-build-hello-worlds.patch"
- patch -p1 < "$srcdir/0003-Fix-installation-directories.patch"
- patch -p1 < "$srcdir/0004-Fix-install-location-of-cmake-config-files.patch"
- patch -p1 < "$srcdir/0005-Build-shared-instead-of-static-library.patch"
+ for f in "${source[@]}"; do
+ if [[ "$f" == *.patch ]]; then
+ patch -p1 < "$srcdir/$f"
+ fi
+ done
}
build() {