summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumit Sahrawat2021-08-02 10:32:23 +0530
committerSumit Sahrawat2021-08-02 10:32:59 +0530
commitf4b0647079e6d88ce47dd1110bbd02ab0364bcc6 (patch)
treebc948a5dfecc55d087e2fbea666c310725312459
parent3f036b3b4cfac8c85dbc175c6961ddfbd0b16140 (diff)
downloadaur-f4b0647079e6d88ce47dd1110bbd02ab0364bcc6.tar.gz
Use .tar.gz instead of git, make config.h optional
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--config.h192
-rw-r--r--surf.install14
5 files changed, 28 insertions, 226 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e224f7a34e..101e16a0dd1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = surf
pkgdesc = A simple web browser based on WebKit/GTK+.
pkgver = 2.1
- pkgrel = 2
+ pkgrel = 3
url = https://surf.suckless.org/
install = surf.install
arch = x86_64
license = MIT
- makedepends = git
depends = webkit2gtk
depends = gcr
depends = xorg-xprop
@@ -14,10 +13,7 @@ pkgbase = surf
optdepends = ca-certificates: SSL verification
optdepends = xterm: default download handler
optdepends = curl: default download handler
- source = git+git://git.suckless.org/surf#commit=d75c3ded0b1ebb8e2778961c5a928f247798686a
- source = config.h
- sha256sums = SKIP
- sha256sums = 02a630a13d800c4baf3dd8eab8712c38de071ee15f8b6820942828cd2b1958a1
+ source = https://dl.suckless.org/surf/surf-2.1.tar.gz
+ sha256sums = 72e582920ba25a646203e93c2d2331d87f03037a28894d6c7e99af00ee043257
pkgname = surf
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..094a01e15a75
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.pkg.tar.zst
+/*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
index 50311831ac43..651280a8a86a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Yusuf Aktepe <yusuf@yusufaktepe.com>
+# Maintainer: Sumit Sahrawat <archlinux at sums dot rs>
+# Contributor: Yusuf Aktepe <yusuf@yusufaktepe.com>
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Pierre Chapuis <catwell at archlinux dot us>
# Contributor: Ray Kohler <ataraxia937 at gmail dot com>
@@ -7,7 +8,7 @@
pkgname=surf
pkgver=2.1
-pkgrel=2
+pkgrel=3
pkgdesc='A simple web browser based on WebKit/GTK+.'
arch=('x86_64')
url='https://surf.suckless.org/'
@@ -17,33 +18,26 @@ optdepends=('dmenu: URL-bar'
'ca-certificates: SSL verification'
'xterm: default download handler'
'curl: default download handler')
-makedepends=('git')
+makedepends=()
install='surf.install'
-_commit=d75c3ded0b1ebb8e2778961c5a928f247798686a
-source=("git+git://git.suckless.org/surf#commit=$_commit"
- "config.h")
-sha256sums=('SKIP'
- '02a630a13d800c4baf3dd8eab8712c38de071ee15f8b6820942828cd2b1958a1')
-
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/-/+/g'
-}
+source=("https://dl.suckless.org/surf/surf-${pkgver}.tar.gz")
+sha256sums=('72e582920ba25a646203e93c2d2331d87f03037a28894d6c7e99af00ee043257')
prepare() {
- cd $pkgname
- cp "$srcdir/config.h" config.h
+ if [[ -f config.h ]]; then
+ cp config.h "${pkgname}-${pkgver}/config.h"
+ fi
}
build() {
- cd $pkgname
- make
+ cd "${pkgname}-${pkgver}"
+ make
}
package() {
- cd $pkgname
+ cd "${pkgname}-${pkgver}"
- make PREFIX=/usr DESTDIR="$pkgdir" install
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/config.h b/config.h
deleted file mode 100644
index ef447213e85a..000000000000
--- a/config.h
+++ /dev/null
@@ -1,192 +0,0 @@
-/* modifier 0 means no modifier */
-static int surfuseragent = 1; /* Append Surf version to default WebKit user agent */
-static char *fulluseragent = ""; /* Or override the whole user agent string */
-static char *scriptfile = "~/.surf/script.js";
-static char *styledir = "~/.surf/styles/";
-static char *certdir = "~/.surf/certificates/";
-static char *cachedir = "~/.surf/cache/";
-static char *cookiefile = "~/.surf/cookies.txt";
-
-/* Webkit default features */
-/* Highest priority value will be used.
- * Default parameters are priority 0
- * Per-uri parameters are priority 1
- * Command parameters are priority 2
- */
-static Parameter defconfig[ParameterLast] = {
- /* parameter Arg value priority */
- [AccessMicrophone] = { { .i = 0 }, },
- [AccessWebcam] = { { .i = 0 }, },
- [Certificate] = { { .i = 0 }, },
- [CaretBrowsing] = { { .i = 0 }, },
- [CookiePolicies] = { { .v = "@Aa" }, },
- [DefaultCharset] = { { .v = "UTF-8" }, },
- [DiskCache] = { { .i = 1 }, },
- [DNSPrefetch] = { { .i = 0 }, },
- [Ephemeral] = { { .i = 0 }, },
- [FileURLsCrossAccess] = { { .i = 0 }, },
- [FontSize] = { { .i = 12 }, },
- [FrameFlattening] = { { .i = 0 }, },
- [Geolocation] = { { .i = 0 }, },
- [HideBackground] = { { .i = 0 }, },
- [Inspector] = { { .i = 0 }, },
- [Java] = { { .i = 1 }, },
- [JavaScript] = { { .i = 1 }, },
- [KioskMode] = { { .i = 0 }, },
- [LoadImages] = { { .i = 1 }, },
- [MediaManualPlay] = { { .i = 1 }, },
- [PreferredLanguages] = { { .v = (char *[]){ NULL } }, },
- [RunInFullscreen] = { { .i = 0 }, },
- [ScrollBars] = { { .i = 1 }, },
- [ShowIndicators] = { { .i = 1 }, },
- [SiteQuirks] = { { .i = 1 }, },
- [SmoothScrolling] = { { .i = 0 }, },
- [SpellChecking] = { { .i = 0 }, },
- [SpellLanguages] = { { .v = ((char *[]){ "en_US", NULL }) }, },
- [StrictTLS] = { { .i = 1 }, },
- [Style] = { { .i = 1 }, },
- [WebGL] = { { .i = 0 }, },
- [ZoomLevel] = { { .f = 1.0 }, },
-};
-
-static UriParameters uriparams[] = {
- { "(://|\\.)suckless\\.org(/|$)", {
- [JavaScript] = { { .i = 0 }, 1 },
- }, },
-};
-
-/* default window size: width, height */
-static int winsize[] = { 800, 600 };
-
-static WebKitFindOptions findopts = WEBKIT_FIND_OPTIONS_CASE_INSENSITIVE |
- WEBKIT_FIND_OPTIONS_WRAP_AROUND;
-
-#define PROMPT_GO "Go:"
-#define PROMPT_FIND "Find:"
-
-/* SETPROP(readprop, setprop, prompt)*/
-#define SETPROP(r, s, p) { \
- .v = (const char *[]){ "/bin/sh", "-c", \
- "prop=\"$(printf '%b' \"$(xprop -id $1 $2 " \
- "| sed \"s/^$2(STRING) = //;s/^\\\"\\(.*\\)\\\"$/\\1/\")\" " \
- "| dmenu -p \"$4\" -w $1)\" && xprop -id $1 -f $3 8s -set $3 \"$prop\"", \
- "surf-setprop", winid, r, s, p, NULL \
- } \
-}
-
-/* DOWNLOAD(URI, referer) */
-#define DOWNLOAD(u, r) { \
- .v = (const char *[]){ "st", "-e", "/bin/sh", "-c",\
- "curl -g -L -J -O -A \"$1\" -b \"$2\" -c \"$2\"" \
- " -e \"$3\" \"$4\"; read", \
- "surf-download", useragent, cookiefile, r, u, NULL \
- } \
-}
-
-/* PLUMB(URI) */
-/* This called when some URI which does not begin with "about:",
- * "http://" or "https://" should be opened.
- */
-#define PLUMB(u) {\
- .v = (const char *[]){ "/bin/sh", "-c", \
- "xdg-open \"$0\"", u, NULL \
- } \
-}
-
-/* VIDEOPLAY(URI) */
-#define VIDEOPLAY(u) {\
- .v = (const char *[]){ "/bin/sh", "-c", \
- "mpv --really-quiet \"$0\"", u, NULL \
- } \
-}
-
-/* styles */
-/*
- * The iteration will stop at the first match, beginning at the beginning of
- * the list.
- */
-static SiteSpecific styles[] = {
- /* regexp file in $styledir */
- { ".*", "default.css" },
-};
-
-/* certificates */
-/*
- * Provide custom certificate for urls
- */
-static SiteSpecific certs[] = {
- /* regexp file in $certdir */
- { "://suckless\\.org/", "suckless.org.crt" },
-};
-
-#define MODKEY GDK_CONTROL_MASK
-
-/* hotkeys */
-/*
- * If you use anything else but MODKEY and GDK_SHIFT_MASK, don't forget to
- * edit the CLEANMASK() macro.
- */
-static Key keys[] = {
- /* modifier keyval function arg */
- { MODKEY, GDK_KEY_g, spawn, SETPROP("_SURF_URI", "_SURF_GO", PROMPT_GO) },
- { MODKEY, GDK_KEY_f, spawn, SETPROP("_SURF_FIND", "_SURF_FIND", PROMPT_FIND) },
- { MODKEY, GDK_KEY_slash, spawn, SETPROP("_SURF_FIND", "_SURF_FIND", PROMPT_FIND) },
-
- { 0, GDK_KEY_Escape, stop, { 0 } },
- { MODKEY, GDK_KEY_c, stop, { 0 } },
-
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_r, reload, { .i = 1 } },
- { MODKEY, GDK_KEY_r, reload, { .i = 0 } },
-
- { MODKEY, GDK_KEY_l, navigate, { .i = +1 } },
- { MODKEY, GDK_KEY_h, navigate, { .i = -1 } },
-
- /* vertical and horizontal scrolling, in viewport percentage */
- { MODKEY, GDK_KEY_j, scrollv, { .i = +10 } },
- { MODKEY, GDK_KEY_k, scrollv, { .i = -10 } },
- { MODKEY, GDK_KEY_space, scrollv, { .i = +50 } },
- { MODKEY, GDK_KEY_b, scrollv, { .i = -50 } },
- { MODKEY, GDK_KEY_i, scrollh, { .i = +10 } },
- { MODKEY, GDK_KEY_u, scrollh, { .i = -10 } },
-
-
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_j, zoom, { .i = -1 } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_k, zoom, { .i = +1 } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_q, zoom, { .i = 0 } },
- { MODKEY, GDK_KEY_minus, zoom, { .i = -1 } },
- { MODKEY, GDK_KEY_plus, zoom, { .i = +1 } },
-
- { MODKEY, GDK_KEY_p, clipboard, { .i = 1 } },
- { MODKEY, GDK_KEY_y, clipboard, { .i = 0 } },
-
- { MODKEY, GDK_KEY_n, find, { .i = +1 } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_n, find, { .i = -1 } },
-
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_p, print, { 0 } },
- { MODKEY, GDK_KEY_t, showcert, { 0 } },
-
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_a, togglecookiepolicy, { 0 } },
- { 0, GDK_KEY_F11, togglefullscreen, { 0 } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_o, toggleinspector, { 0 } },
-
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_c, toggle, { .i = CaretBrowsing } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_f, toggle, { .i = FrameFlattening } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_g, toggle, { .i = Geolocation } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_s, toggle, { .i = JavaScript } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_i, toggle, { .i = LoadImages } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_b, toggle, { .i = ScrollBars } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_t, toggle, { .i = StrictTLS } },
- { MODKEY|GDK_SHIFT_MASK, GDK_KEY_m, toggle, { .i = Style } },
-};
-
-/* button definitions */
-/* target can be OnDoc, OnLink, OnImg, OnMedia, OnEdit, OnBar, OnSel, OnAny */
-static Button buttons[] = {
- /* target event mask button function argument stop event */
- { OnLink, 0, 2, clicknewwindow, { .i = 0 }, 1 },
- { OnLink, MODKEY, 2, clicknewwindow, { .i = 1 }, 1 },
- { OnLink, MODKEY, 1, clicknewwindow, { .i = 1 }, 1 },
- { OnAny, 0, 8, clicknavigate, { .i = -1 }, 1 },
- { OnAny, 0, 9, clicknavigate, { .i = +1 }, 1 },
- { OnMedia, MODKEY, 1, clickexternplayer, { 0 }, 1 },
-};
diff --git a/surf.install b/surf.install
index 8aaf9f94ef13..126c0aa6bccd 100644
--- a/surf.install
+++ b/surf.install
@@ -1,13 +1,13 @@
post_install() {
- while read; do
- printf '%s\n' "$REPLY"
- done <<-EOF
- ==> Edit config.h in PKGBUILD's directory
- ==> and rebuild the package if you want to change settings.
- EOF
+ while read; do
+ printf '%s\n' "$REPLY"
+ done <<-EOF
+ ==> Add a config.h in PKGBUILD's directory
+ ==> and rebuild the package if you want to change settings.
+ EOF
}
post_upgrade() {
- post_install
+ post_install
}