summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Luz2019-09-08 23:41:28 +0200
committerMaximilian Luz2019-09-08 23:41:28 +0200
commit01eea3f66e0057393cc4fcb841941aefbbef5397 (patch)
tree7979bb310d580a57d30a0cb0c3cec1f974a06f74
downloadaur-01eea3f66e0057393cc4fcb841941aefbbef5397.tar.gz
Initial release
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e62cac90bd5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = surface-control
+ pkgdesc = Control various aspects of Microsoft Surface devices from the Command-Line
+ pkgver = 0.2.3
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ depends = gcc-libs
+ source = src::git+https://github.com/qzed/linux-surface-control.git#tag=v0.2.3
+ sha256sums = SKIP
+
+pkgname = surface-control
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ed9fa3dcdcc2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src
+pkg
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c41aab8a25d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Maximilian Luz <luzmaximilian@gmail.com>
+
+pkgname="surface-control"
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='Control various aspects of Microsoft Surface devices from the Command-Line'
+license=('MIT')
+arch=('x86_64')
+depends=('gcc-libs')
+makedepends=('rust' 'cargo')
+
+source=(
+ "src::git+https://github.com/qzed/linux-surface-control.git#tag=v${pkgver}"
+)
+
+sha256sums=(
+ 'SKIP'
+)
+
+build(){
+ cd "src"
+ env CARGO_TARGET_DIR="target" CARGO_INCREMENTAL=0 cargo build --release --locked
+ strip --strip-all "target/release/surface"
+}
+
+package() {
+ install -D -m755 "src/target/release/surface" "$pkgdir/usr/bin/surface"
+
+ # completion files
+ install -D -m644 "src/target/surface.bash" "$pkgdir/usr/share/bash-completion/completions/surface"
+ install -D -m644 "src/target/_surface" "$pkgdir/usr/share/zsh/site-functions/_surface"
+ install -D -m644 "src/target/surface.fish" "$pkgdir/usr/share/fish/completions/surface.fish"
+
+ # license
+ install -Dm644 "src/LICENSE" "${pkgdir}/usr/share/licenses/surface-control/LICENSE"
+}