summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Luz2021-02-05 04:30:07 +0100
committerMaximilian Luz2021-02-05 04:30:07 +0100
commitd1a7222fdd6b06ddf7b604ca547a88cf2da30bfd (patch)
treee83509a9af360efe17d4f4769ef5083d44787a0d
parent834c5b65dddc3f30d868f7711baeea781f67f09a (diff)
downloadaur-d1a7222fdd6b06ddf7b604ca547a88cf2da30bfd.tar.gz
Update to v0.3.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index faf1cf65e778..59d2b58cf01e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = surface-control
pkgdesc = Control various aspects of Microsoft Surface devices from the Command-Line
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/linux-surface/surface-control
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = surface-control
makedepends = rust
makedepends = cargo
depends = gcc-libs
- source = surface-control::git+https://github.com/linux-surface/surface-control.git#tag=v0.3.0-1
+ source = surface-control::git+https://github.com/linux-surface/surface-control.git#tag=v0.3.1-1
sha256sums = SKIP
pkgname = surface-control
diff --git a/PKGBUILD b/PKGBUILD
index de7b68e1c2e3..37dd3e880a6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maximilian Luz <luzmaximilian@gmail.com>
pkgname="surface-control"
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
_pkgrel=1
pkgdesc='Control various aspects of Microsoft Surface devices from the Command-Line'
@@ -26,6 +26,10 @@ build(){
package() {
install -D -m755 "${srcdir}/${pkgname}/target/release/surface" "$pkgdir/usr/bin/surface"
+ # copy system files
+ install -D -m644 "${srcdir}/${pkgname}/etc/sysusers/surface-control.conf" "${pkgdir}/usr/lib/sysusers.d/surface-control.conf"
+ install -D -m644 "${srcdir}/${pkgname}/etc/udev/40-surface-control.rules" "${pkgdir}/usr/lib/udev/rules.d/40-surface-control.rules"
+
# completion files
install -D -m644 "${srcdir}/${pkgname}/target/surface.bash" "$pkgdir/usr/share/bash-completion/completions/surface"
install -D -m644 "${srcdir}/${pkgname}/target/_surface" "$pkgdir/usr/share/zsh/site-functions/_surface"