summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSophie 'Sharky' Schumann2019-09-13 02:43:07 +0200
committerSophie 'Sharky' Schumann2019-09-13 02:43:07 +0200
commit8b3504c5baf9f01e5606b9441f178b26d4a6363d (patch)
treeb4680fdacc2e0aa769d2fadfbeb1c2571558e433
parentaefb0251a8b4719f045e3b67fa448e1784de3580 (diff)
downloadaur-8b3504c5baf9f01e5606b9441f178b26d4a6363d.tar.gz
updated to surfshark-vpn v1.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 13 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70083bc22361..add13dabfcc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = surfshark-vpn
pkgdesc = Surfshark Linux client
- pkgver = 0.4.8
+ pkgver = 1.0.0
pkgrel = 1
url = https://surfshark.com/download/linux
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = surfshark-vpn
depends = openvpn
options = libtool
options = staticlibs
- source = https://ocean.surfshark.com/debian/pool/main/s/surfshark-vpn/surfshark-vpn_0.4.8_amd64.deb
+ source = https://ocean.surfshark.com/debian/pool/main/s/surfshark-vpn/surfshark-vpn_1.0.0_amd64.deb
validpgpkeys = 9337E0FFC604A322352A55606253B09AEA6AE9E1
- md5sums = 9afe5ae814038027d5c5292f5c38cce6
- sha256sums = e76eb57b39e99c51b5307bd56ce3cff5543617c08130616aefd2a0b009a38a8d
- sha512sums = e6879a5e958b31387ef1efe862e8a7ad5268f52178fb9b84159255360a1716a9773faefb6bc5037fd2bbad961d1257b787eed234893bcecc8d6e0bbff4971175
+ md5sums = b4dcf2d304c8d294d622b5259d638fe0
+ sha256sums = 0e11d87113bc7adfdcaa0ee2e66bebedb3f1964f897eb6552057e91282629f56
+ sha512sums = b79fd876c90c79128bdcaf11bf723a32d9ac6a44456115aa59fe536d6af168e4b0c2bc5b48da74fba553baaf056c44d3ea043d97a12f9447d16f936bf45c71c9
pkgname = surfshark-vpn
diff --git a/PKGBUILD b/PKGBUILD
index 2c4f8d433c40..15e9321d8e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,18 @@
# Maintainer: Sharky <sharky@sharky.pw>
pkgname=surfshark-vpn
-pkgver=0.4.8
+pkgver=1.0.0
pkgrel=1
epoch=
pkgdesc="Surfshark Linux client"
arch=('x86_64')
url="https://surfshark.com/download/linux"
license=('custom:surfshark')
-groups=()
depends=(glibc openvpn)
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
options=(libtool staticlibs)
-install=
-changelog=
source=("https://ocean.surfshark.com/debian/pool/main/s/surfshark-vpn/surfshark-vpn_${pkgver}_amd64.deb")
-md5sums=('9afe5ae814038027d5c5292f5c38cce6')
-sha256sums=('e76eb57b39e99c51b5307bd56ce3cff5543617c08130616aefd2a0b009a38a8d')
-sha512sums=('e6879a5e958b31387ef1efe862e8a7ad5268f52178fb9b84159255360a1716a9773faefb6bc5037fd2bbad961d1257b787eed234893bcecc8d6e0bbff4971175')
+md5sums=('b4dcf2d304c8d294d622b5259d638fe0')
+sha256sums=('0e11d87113bc7adfdcaa0ee2e66bebedb3f1964f897eb6552057e91282629f56')
+sha512sums=('b79fd876c90c79128bdcaf11bf723a32d9ac6a44456115aa59fe536d6af168e4b0c2bc5b48da74fba553baaf056c44d3ea043d97a12f9447d16f936bf45c71c9')
noextract=()
validpgpkeys=("9337E0FFC604A322352A55606253B09AEA6AE9E1")
@@ -32,9 +22,8 @@ prepare() {
package() {
- mkdir -p "$pkgdir/usr/local/sbin/" "$pkgdir/usr/share/man/man8/"
- install -Dm 750 "$srcdir/usr/bin/surfshark-vpn" "$pkgdir/usr/local/sbin/" -g root -o root
- install -Dm 644 "$srcdir/usr/share/doc/surfshark-vpn/changelog.gz" "$pkgdir/usr/share/doc/changelog.gz" -o root -g root
- install -Dm 644 "$srcdir/usr/share/doc/surfshark-vpn/copyright" "$pkgdir/usr/share/doc/changelog.gz" -o root -g root
- install -Dm 644 "$srcdir/usr/share/man/man8/surfshark-vpn.8.gz" "$pkgdir/usr/share/man/man8/" -o root -g root
+ mkdir -p "${pkgdir}/usr/local/sbin/"
+ install -Dm 750 "${srcdir}/usr/bin/surfshark-vpn" "${pkgdir}/usr/local/sbin/" -g root -o root
+ install -Dm 644 "${srcdir}/usr/share/doc/surfshark-vpn/changelog.gz" "${pkgdir}/usr/share/doc/${pkgname}/changelog.gz" -o root -g root
+ install -Dm 644 "${srcdir}/usr/share/doc/surfshark-vpn/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" -o root -g root
}