summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosch2019-05-15 19:42:15 +0200
committerosch2019-05-15 23:12:59 +0200
commit50213feac7ebfca193e45737a69645162b01f85e (patch)
tree72d7e520bed4929f2ad5dfe82e2270b83e1937b7
downloadaur-50213feac7ebfca193e45737a69645162b01f85e.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD66
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07a3caab2883
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = surge-synthesizer
+ pkgdesc = Surge Synthesizer plugin
+ pkgver = 1.6.0b9
+ pkgrel = 1
+ url = https://surge-synthesizer.github.io
+ arch = x86_64
+ groups = vst-plugins
+ license = GPL3
+ makedepends = steinberg-vst
+ makedepends = premake5
+ makedepends = git
+ depends = cairo
+ depends = fontconfig
+ depends = freetype2
+ depends = libx11
+ depends = xcb-util-cursor
+ depends = xcb-util
+ depends = libxcb
+ depends = xcb-util-renderutil
+ depends = xcb-util-image
+ provides = surge-synthesizer
+ conflicts = surge-synthesizer
+
+pkgname = surge-synthesizer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd1cf2960d75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: osch <oliver@luced.de>
+pkgname=surge-synthesizer
+pkgver=1.6.0b9
+scmver=1.6.0-beta-9
+pkgrel=1
+pkgdesc="Surge Synthesizer plugin"
+arch=('x86_64')
+url="https://surge-synthesizer.github.io"
+license=('GPL3')
+groups=('vst-plugins')
+depends=('cairo' 'fontconfig' 'freetype2'
+ 'libx11' 'xcb-util-cursor' 'xcb-util'
+ 'libxcb' 'xcb-util-renderutil' 'xcb-util-image'
+ )
+makedepends=('steinberg-vst' 'premake5' 'git')
+provides=("surge-synthesizer")
+conflicts=('surge-synthesizer')
+options=()
+
+prepare() {
+ export VST2SDK_DIR="$srcdir/vst2sdk"
+
+ cd "$srcdir"
+ rm -rf vst2sdk
+ mkdir vst2sdk
+ cd vst2sdk
+ # Workaround for steinberg-vst36.git:
+ ln -s /usr/include/vst36/pluginterfaces .
+ mkdir -p public.sdk/source/
+ cd public.sdk/source/
+ ln -s /usr/include/vst36 vst2.x
+
+ cd "$srcdir"
+ if [ -d surge ]; then
+ cd surge
+ git pull
+ else
+ git clone https://github.com/surge-synthesizer/surge.git
+ cd surge
+ fi
+ git submodule update --init --recursive
+ git checkout release/$scmver
+
+ sed -i -e 's:dest_path="/:dest_path="$DEST_DIR/:' build-linux.sh
+ sed -i -e 's:data_path="/:data_path="$DEST_DIR/:' build-linux.sh
+ echo "$scmver" > VERSION
+}
+
+build() {
+ export VST2SDK_DIR="$srcdir/vst2sdk"
+ cd "$srcdir/surge"
+ export MAKEFLAGS="-j1"
+ ./build-linux.sh -p vst2 build
+}
+
+package() {
+ export VST2SDK_DIR="$srcdir/vst2sdk"
+ cd "$srcdir/surge"
+ export DEST_DIR="$pkgdir"
+ mkdir -p "$DEST_DIR/usr/share"
+ mkdir -p "$DEST_DIR/usr/lib/vst"
+ export MAKEFLAGS="-j1"
+ ./build-linux.sh -p vst2 install
+ mkdir -p "$DEST_DIR/usr/share/Surge/doc"
+ cp LICENSE "$DEST_DIR/usr/share/Surge/doc"
+}