summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Reis2019-02-13 20:17:59 -0200
committerGustavo Reis2019-02-13 20:17:59 -0200
commitc01952f51c67ea581fd2f6b38e66f7b048a9b2f4 (patch)
tree27dbfec01f50b35d09bcb12519d492c1483d8cca
parente16b48eeddfd0e18edafbb599f652e130152a90d (diff)
downloadaur-c01952f51c67ea581fd2f6b38e66f7b048a9b2f4.tar.gz
Upgraded from Suru++ 25
-rw-r--r--.SRCINFO7
-rwxr-xr-xCHANGELOG25
-rw-r--r--PKGBUILD28
3 files changed, 41 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88b563435534..43f5aee9a2db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = suru-plus-dark-git
- pkgdesc = A dark and elegant third-party icons, based on Sam Hewitt's Suru Icons
- pkgver = r1.1
+ pkgdesc = Suru++ 25 Dark – A full dark cyberpunk third-party icons theme!
+ pkgver = 25.0
pkgrel = 1
url = https://github.com/gusbemacbe/suru-plus-dark
+ changelog = CHANGELOG
arch = any
license = GPL3
makedepends = git
+ provides = suru-plus-dark
conflicts = suru-plus-dark
- options = !strip
source = git+https://github.com/gusbemacbe/suru-plus-dark.git
sha256sums = SKIP
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100755
index 000000000000..bf840b973938
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,25 @@
+GREEN='\033[0;32m'
+ORANGE='\033[0;33m'
+PURPLE='\033[0;35m'
+RED='\033[0;31m'
+
+LGREEN='\033[1;32m'
+YELLOW='\033[1;33m'
+LPURPLE='\033[1;35m'
+LRED='\033[1;31m'
+WHITE='\033[1;37m'
+
+NC='\033[0m' # No Color
+
+echo -e "${GREEN}#${NC} ${ORANGE}25.0.0${NC}"
+echo -e "* Upgraded and renamed to Suru++ 25 Dark"
+
+echo -e " "
+
+echo -e "${GREEN}#${NC} ${ORANGE}20.3.2${NC}"
+echo -e "* “Clean” to “uninstall” fixed by @jonathonf"
+
+echo -e " "
+
+echo -e "${GREEN}#${NC} ${ORANGE}20.3.1${NC}"
+echo -e "* Makefile added by @jonathonf"
diff --git a/PKGBUILD b/PKGBUILD
index 9b41f8e7a089..d6baa0d03043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,28 @@
-# Contributor: Daniel Miranda <dmiranda at gmail dot com>
-# Maintainer: Gustavo Costa <gusbemacbe@gmail.com>
+# Contributor: Daniel Miranda (dmiranda)
+# Contributor: Fabio ‘Lolix’ Loli <lolix at disroot dot org>
+# Contributor: Jonathon <jonathonf>
+# Maintainer: Gustavo Costa (gusbemacbe)
-_gitname=suru-plus-dark
pkgname=suru-plus-dark-git
-pkgver=r1.1
+pkgver=25.0
pkgrel=1
-pkgdesc="A dark and elegant third-party icons, based on Sam Hewitt's Suru Icons"
+pkgdesc="Suru++ 25 Dark – A full dark cyberpunk third-party icons theme!"
arch=('any')
-url="https://github.com/gusbemacbe/${_gitname}"
+url="https://github.com/gusbemacbe/${pkgname/-git/}"
license=('GPL3')
+changelog=CHANGELOG
makedepends=('git')
-options=('!strip')
-conflicts=(${_gitname})
+conflicts=(${pkgname/-git/})
+provides=(${pkgname/-git/})
source=("git+${url}.git")
sha256sums=('SKIP')
pkgver()
{
- cd ${_gitname}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C ${pkgname/-git/} describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
package()
{
- install -d ${pkgdir}/usr/share/icons
- cp -r ${srcdir}/${_gitname}* ${pkgdir}/usr/share/icons/
- find ${pkgdir}/usr -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr -type d -exec chmod 755 {} \;
- find ${pkgdir}/usr -type f -name '.directory' -delete
- rm -rf "$pkgdir"/usr/share/icons/suru-plus-dark/{configure, .git, .github, .gitattributes, .gitignore,*.md,*.jpg,*.svg,*.png, .product, 'nuove icone', 'Suru++ OpenDesktop'}
+ make -C ${pkgname/-git/} DESTDIR="$pkgdir/" install
}