summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-04-05 21:17:34 -0500
committerHurricanePootis2024-04-05 21:17:34 -0500
commitacf4f882ef83cdb0465aa600cb50eb01c94865d8 (patch)
treee5aaf8390f5d715774e1ae3719272e2729fa0f0e
parentf682f86f9868991c78dcc7c87141781691dd89e5 (diff)
downloadaur-acf4f882ef83cdb0465aa600cb50eb01c94865d8.tar.gz
Add back vcpkg submodule now that curl bug is fixed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbb44d0b2ee8..ba9683c36172 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = suyu-dev-git
pkgdesc = suyu is the afterlife the world's most popular, open-source, Nintendo Switch emulator (dev branch)
- pkgver = r27347.d3f67d1e9c
+ pkgver = r27354.b911ac8516
pkgrel = 1
url = https://git.suyu.dev/suyu/suyu
install = suyu-dev-git.install
@@ -67,6 +67,7 @@ pkgbase = suyu-dev-git
source = git+https://github.com/libsdl-org/SDL.git
source = git+https://github.com/yhirose/cpp-httplib.git
source = ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git
+ source = git+https://github.com/microsoft/vcpkg.git
source = git+https://github.com/arun11299/cpp-jwt.git
source = git+https://github.com/bylaws/libadrenotools.git
source = git+https://github.com/lat9nq/tzdb_to_nx.git
@@ -107,5 +108,6 @@ pkgbase = suyu-dev-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = SKIP
pkgname = suyu-dev-git
diff --git a/PKGBUILD b/PKGBUILD
index a3560ed649a0..89885f174b72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=suyu
_branch=dev
pkgname=suyu-dev-git
-pkgver=r27347.d3f67d1e9c
+pkgver=r27354.b911ac8516
pkgrel=1
pkgdesc="suyu is the afterlife the world's most popular, open-source, Nintendo Switch emulator (dev branch)"
arch=(x86_64)
@@ -74,6 +74,7 @@ source=(
git+https://github.com/libsdl-org/SDL.git
git+https://github.com/yhirose/cpp-httplib.git
ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git
+ git+https://github.com/microsoft/vcpkg.git
git+https://github.com/arun11299/cpp-jwt.git
git+https://github.com/bylaws/libadrenotools.git
git+https://github.com/lat9nq/tzdb_to_nx.git
@@ -115,6 +116,7 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -124,7 +126,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {enet,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,SDL,cpp-httplib,ffmpeg,cpp-jwt,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad,simpleini,oaknut,Vulkan-Utility-Libraries};
+ for submodule in {enet,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,SDL,cpp-httplib,ffmpeg,vcpkg,cpp-jwt,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad,simpleini,oaknut,Vulkan-Utility-Libraries};
do
git config --file=.gitmodules submodule.$submodule.url "${srcdir}"/$submodule
done