summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwido2016-04-15 00:24:20 +0200
committerwido2016-04-15 00:24:20 +0200
commita6fb09586417aaa24c77258408049bce4765bcfa (patch)
treea6a8c0f70efe7f4f923ba5e87c7d86872cf7867a
downloadaur-a6fb09586417aaa24c77258408049bce4765bcfa.tar.gz
origin
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc6d2152812f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = svfs
+ pkgdesc = The Swift Virtual File System for hubiC (ovh)
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/ovh/svfs
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = fuse
+ depends = ruby
+ provides = svfs
+ conflicts = svfs-git
+ source_i686 = https://github.com/ovh/svfs/releases/download/v0.5.1/svfs_0.5.1_386.deb
+ md5sums_i686 = eb07ec1aea5462db4fe19382e0fbf106
+ source_x86_64 = https://github.com/ovh/svfs/releases/download/v0.5.1/svfs_0.5.1_amd64.deb
+ md5sums_x86_64 = 851ef4ccffa447de858350f7101c7852
+
+pkgname = svfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21c9012e86ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Flow
+
+pkgname=svfs
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="The Swift Virtual File System for hubiC (ovh)"
+arch=('i686' 'x86_64')
+conflicts=("svfs-git")
+provides=("svfs")
+url='https://github.com/ovh/svfs'
+license=('BSD')
+depends=('fuse' 'ruby')
+makedepends=()
+source_x86_64=("https://github.com/ovh/svfs/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb")
+source_i686=("https://github.com/ovh/svfs/releases/download/v${pkgver}/${pkgname}_${pkgver}_386.deb")
+md5sums_i686=('eb07ec1aea5462db4fe19382e0fbf106')
+md5sums_x86_64=('851ef4ccffa447de858350f7101c7852')
+
+package() {
+ cd "${srcdir}"
+ tar -xzf data.tar.gz -C "${srcdir}"
+ install -Dm755 "${srcdir}"/usr/local/bin/hubic-application "${pkgdir}"/usr/bin/hubic-application
+ install -Dm755 "${srcdir}"/usr/local/bin/svfs "${pkgdir}"/usr/bin/svfs
+ install -Dm755 "${srcdir}"/sbin/mount.svfs "${pkgdir}"/usr/bin/mount.svfs
+}